Facebook Like Button

FYI: This old forum site will not be updated anymore. To post a new topic, please click here to register to our new spacedesk Forum site.
Share:
Notifications
Clear all

Wrong color  


JamesZhu3rd
Posts: 5
Registered
(@jameszhu3rd)
Active Member
Joined: 10 months ago
The connection was successful but the images were not displayed in the right colors(blurred with rainbow colors). Also the network sending speed is not very high.
 
- Primary machine operating system
Window10 20H2 R7 3800X
- Secondary machine operating system
Android oneplus 7 pro & Samsung Galaxy Tab S7+
- Primary machines's Graphics adapter
AMD RX 5700XT
- Network connection type
Wireless & Hotspot
 
Thanks
Topic Tags
AMD
7 Replies
spacedesk Lea
Posts: 2724
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @jameszhu,
For further analysis, could you please run dxdiag.exe on your primary machine, click "Save All Information", then attach the output file (dxdiag.txt) on your next reply.
Could you also send us a screenshot that shows the wrong colors?
PS: Attach option should be visible on your side after your second post.

Reply
JamesZhu3rd
Posts: 5
Registered
(@jameszhu3rd)
Active Member
Joined: 10 months ago

the screenshot

Reply
JamesZhu3rd
Posts: 5
Registered
(@jameszhu3rd)
Active Member
Joined: 10 months ago
Posted by: @jameszhu3rd

the screenshot

 

Reply
JamesZhu3rd
Posts: 5
Registered
(@jameszhu3rd)
Active Member
Joined: 10 months ago
Posted by: @spacedesklea

dxdiag.txt

 

Reply
spacedesk Lea
Posts: 2724
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @jameszhu3rd,
Thanks for sending the requested files.
Could you please try to update your AMD driver to the most recent version.
You can download the driver installer from their website: https://www.amd.com/en/support/graphics/amd-radeon-5700-series/amd-radeon-rx-5700-series/amd-radeon-rx-5700-xt

After the driver update, please reboot your primary machine and try again with spacedesk.
Then let us know if the problem still persist.

Reply
CP2
Posts: 5
 CP2
Registered
(@cp2)
Active Member
Joined: 1 year ago

@jameszhu3rd, I've had this issue and believe I know how to resolve it for you, if Lea's suggestion has not worked.  

I also have an AMD GPU and experienced the same issue previously.    I have a HDR monitor, and had the option under Graphics -> Advanced for "10-bit Pixel Format' enabled.   

Disable this option, and your colors should return to normal when you use SpaceDesk. 

@spacedesklea - I've seen this issue going on at least the last five months through different AMD driver versions and multiple Spacedesk server & viewer versions.  Spacedesk seems to be the only app that doesn't work correctly with 10-bit Pixel format enabled, however. 

Reply
spacedesk Lea
Posts: 2724
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @cp2,
Thank you very much for this information - very helpful!

Reply

spacedesk forum footer

Copyright © 2020 spacedesk Support Forum