Facebook Like Button

Welcome Visitor! Please Login or Register
USB Tethering on Ga...
 
Share:
Notifications
Clear all

USB Tethering on Galaxy Tab S7+  


johpe
Posts: 2
Registered
(@johpe)
New Member
Joined: 4 months ago

Hi there

I've got a Samsung Galaxy Tab S7+ Wi-Fi only version and running spacedesk over Wi-Fi works fine but it is a little bit too laggy so I wanted to use the USB Tethering instead.

The problem seems to be that since my tablet is WiFi only it doesn't really seem to support tethering completely. When I connect the USB cable I get the option to select which mode I want to use; 'file transfer', 'midi', 'USB tethering', etc.

But when I chose USB Tethering I do not get a correct ip address on the Samsung NDIS interface that shows up in Windows 10, I only get a link local address (169.254.x.x) and my Galaxy tab can't connect to the computer with the spacedesk app.

If I instead test the exact same thing with my Galaxy S20 phone it works, and the only difference I can find is that when I set the phone to USB Tethering the NDIS ethernet interface gets a "real" ip address in the 192.168.x.x range. And then the spacedesk app connect without problems and everything runs really smooth.

So is there a way to work around this? To make spacedesk work on link local addresses?

(I've also tested the "Splashtop XDisplay" app which seems to have the same problem. Then I tested the "Twomon Se" app and that app actually works on my tablet so there should be a way to make it work) 

12 Replies
spacedesk Lea
Posts: 2583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @johpe,
We are not sure if a wiFi only Samsung tablet can do USB tethering.
But since you mentioned that there's a USB tethering option upon plugging the cable maybe you can try to hardcode the IP address of Samsung NDIS Adapter on your Winowds 10 PC?
Can you try the following steps on your Windows 10 PC:
- run ncpa.cpl
- right-click on Samsung NDIS Adapter -> Properties -> select "Internet Protocol Version 4 (TCP/IPv4)" -> click Properties button below
- select "Use the following IP address:" then assign the following:
IP address: 192.168.X.X
Subnet mask: 255.255.255.0

Then try if you can also set the IP address manually on your tablet's network settings, not sure which options to get there since we don't have the same device here to guide you.

Then if USB tethering is really not possible on your tablet, then maybe you can try WiFi Hotspot instead?
Please check "Wifi Direct / Wifi Hotspot / Wifi Access Point" chapter in our user manual https://spacedesk.net/user-manual/.

Reply
johpe
Posts: 2
Registered
(@johpe)
New Member
Joined: 4 months ago

Hi again, thanks for your reply and suggestions.

I've configured the interface in Windows with a static ip with exactly the same addresses that I get when I connect my Galaxy S20 phone, the spacedesk Android app doesn't find the Windows computer anyway and when I try to manually connect to the computers IP address it just shows the "IP-Validation in progress..." dialog and nothing happens. So I'm afraid it didn't work (and I have not been able to find anywhere where I can configure the USB-Tethered IP-address in my tablet. 

It also works fine when I connect a USB-Ethernet dongle to the tablet and connect it to my computer over Ethernet. Then It is really fast and no lagging at all, but with this setup I lose the automatic charging of the tablet that I get when running over USB-Tethering. But the Ethernet dongle didn't work until I configured a real IP-address on it either (in the 192.168.x.x range), when I had it set to DHCP in the tablet and no DHCP-server in the network it defaults to a link local address and then it didn't work either.

So I'm guessing your app just can't find and connect to the PC when using link local addresses? (Since it didn't work with link local over Ethernet but when changing to static IP addresses it just started working directly. it's a pity I can configure a static IP in the tablet when using USB-Tethering to confirm this suspicion.)

As I said in my first post this other app "Twomon SE" actually works over USB-Tethering with my tablet so there has to be some way of making it work.

But I would very much prefer to use your solution since you offer the flexibility of wifi/ethernet/usb and your app seems quicker and less laggy than the other app and it also only supports usb.

So if there is any debugging or syslogs or similar that I can take to help you find a solution to this I would be happy to do that or if you'd like to setup a remote session to debug it... please let me know.

Reply
Monolote
Posts: 3
Registered
(@monolote)
New Member
Joined: 3 weeks ago

Same problem with same tablet, please help!

Reply
spacedesk Lea
Posts: 2583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @monolote,

Did you also get a link local address (169.254.x.x) on the Samsung NDIS interface on your primary machine?

Reply
Monolote
Posts: 3
Registered
(@monolote)
New Member
Joined: 3 weeks ago

Yes, I get this in the Windows PC:

Ethernet Interface: SAMSUNG Mobile USB Remote NDIS Network Device
IP-Address: 169.254.....

But the tablet only detects wifi connection. 

I have another android tablet that works perfectly with wired connetion, so it's something specific with this tablet.

Reply
spacedesk Lea
Posts: 2583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @monolote,

169.254.xxx.xxx IP address is usually happening when computer configured to use automatic IP addressing but is unable to contact a DHCP server.
Can you please try the steps below on your Windows PC with USB tethering already setup:
- Open your Device Manager,
- Find the SAMSUNG Mobile USB Remote NDIS Network Device under the Network adapters
- Right click it and select Update Driver Software
- Select Browse my computer for driver software
- Select Let me pick from a list of device drivers on my computer
- Choose Remote NDIS based Internet Sharing Device and Click Next
After the steps above, please check the assigned IP address if it's still 169.254.x.x or if it's valid now..
Looking forward to your feedback.

Reply
Monolote
Posts: 3
Registered
(@monolote)
New Member
Joined: 3 weeks ago

I change driver as you said, but it still doesn't detect on the tablet. Regarding the IP, this is what I have in PC:

Ethernet Interface: Realtek USB GbE Family Controller
IP-Address: 192.168.0.18

Ethernet Interface: SAMSUNG Mobile USB Remote NDIS Network Device
IP-Address: 169.254.217.200

 

That's the same no mater what driver I choose. 

Reply
spacedesk Lea
Posts: 2583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @monolote,
Ok thanks for quickly trying it.
As of now we don't have a solution for this issue.
This is actually a windows network configuration issue between your Windows PC and USB tethering setup of your android tablet.
Other option is to setup Mobile Hotspot/WiFi Direct connection between your PC and tablet device.

Reply
yfzhao
Posts: 17
Registered
(@yfzhao)
Eminent Member
Joined: 2 months ago

我认为可以使用外置网卡和网线将两个设备连接起来,而不是USB线。

现在我使用这些进行有线连接,看起来工作良好。

不过还是希望支持USB直接连接。

 

Reply
Robertson96
Posts: 3
Registered
(@robertson96)
New Member
Joined: 2 months ago

I have the exact same problem. Have tried a variety of things.

Reply
felix
Posts: 0
Registered
(@felix)
New Member
Joined: 6 days ago

Here I am with the same issue. I will try with the advise above - to setup a Mobile Hotspot/WiFi Direct connection between the PC and the tablet.

Reply
spacedesk Lea
Posts: 2583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @robertson96 and @felix,
Do you also have a link local address (169.254.x.x) too on your USB tethered network?
What is your viewer app and secondary machine? Android/iOS/Windows?

 

Reply

spacedesk forum footer

Copyright © 2020 spacedesk Support Forum