Facebook Like Button

Welcome Visitor! Please Login or Register
USB tethering issue...
 
Share:
Notifications
Clear all

[Solved] USB tethering issues  


diegoarthur
Posts: 4
Registered
(@diegoarthur)
New Member
Joined: 2 weeks ago

- Primary machine operating system: Windows 10
- Secondary machine operating system: Android 10

- Primary machines's Graphics adapter: Nvidia Quadro 3000M - Intel 5000
- Network connection type: USB tethering

Hello,

I am connecting my tablet to my pc using USB tethering, for best results. Problem is, my PC starts to use the tablet as the internet source. My tablet is old, so it does not have 5GHz network, meaning my internet session on windows is not as good as it should be. How do I force windows to use the notebook wireless adapter on this situation?

Thanks.

7 Replies
MaybeQ
Posts: 2
Registered
(@maybeq)
New Member
Joined: 2 weeks ago

Not that I know for sure, but I feel l like Windows automatically uses the better network for connecting to the internet. If you're worried though, you can disable internet connection for a specific network.

  1. Go to Windows Settings > Network & Internet > Change adapter options
  2. Right click on your tethered network ("Ethernet 2" for me) and click on Properties
  3. Uncheck both Internet Protocol Version 4, and Version 6, and click OK.
Reply
diegoarthur
Posts: 4
Registered
(@diegoarthur)
New Member
Joined: 2 weeks ago

Windows believes that being a wired connection he should use it, even though my tablet's wifi is worse than my notebook's. Also, even if I disable the tablet's wifi windows will still prioritize the usb tethering connection for internet, which means I wont have internet on my notebook at all.

I tried the steps you mentioned but by doing that I wont get an IP address on my tablet and wont be able to use spacedesk.

Reply
MaybeQ
Posts: 2
Registered
(@maybeq)
New Member
Joined: 2 weeks ago

Ah you're right, I just spaced out and forgot about needing the IP for Spacedesk. Try this instead of step 3 from before.

  1. Click on Internet Protocol Version 4 and click Properties
  2. Open command prompt and type ipconfig, look for the values under Ethernet 2
  3. In the properties window, select "Use the following IP address" and grab the IPv4 Address and Subnet Mask values from the previous step, leave Default Gateway blank
Reply
spacedesk Lea
Posts: 1086
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @diegoarthur,

This is probably a network adapter priority of your machine.
Could you please try the following:
- Open Windows Settings -> Network and Internet -> Change adapter option
- In there you will see the WiFi adapter, right-click -> Properties, click on Internet Protocol Version 4 (TCP/IPv4) -> Properties -> Advanced
- Uncheck the "Automatic metric" and set the value to any value(e.g. 3), then click OK to finish it.
Then do the same thing with your USB tethering network adapter (Remote NDIS adapter) and make sure it has higher metric value (e.g. 7).
- Reboot your primary machine then try again.
Then let us know if it helps. Looking forward to your feedback.

Reply
diegoarthur
Registered
(@diegoarthur)
Joined: 2 weeks ago

New Member
Posts: 4

Thanks very much, that did work.

Final question: every time I connect the tablet using USB, a new connection is created on Windows 10. I am on network 20 already. Any way to stop this? I searched the web and found some registry edit as solution, but it did no work.

Reply
spacedesk Lea
Posts: 1086
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @diegoarthur,

We are glad that our suggestion helped.
As for you question, this is probably a Windows 10 issue.
I found this thread in the Microsoft forum, can you check and maybe try it if it helps.
https://answers.microsoft.com/en-us/windows/forum/all/usb-tethering-creating-new-names-each-time/3b360d02-578c-46eb-b155-1d899775f29b?tab=AllReplies#tabs

Reply
diegoarthur
Posts: 4
Registered
(@diegoarthur)
New Member
Joined: 2 weeks ago

Thanks for the support! Sadly, I wont expect Microsoft to fix this problem soon.

Reply

spacedesk forum footer

Copyright © 2020 spacedesk Support Forum