Facebook Like Button

Welcome Visitor! Please Login or Register
Share:
Notifications
Clear all

Unable to connect  


donkinc
Posts: 3
Registered
(@donkinc)
New Member
Joined: 4 weeks ago

Hi, hopefully I can provide the information you need to help me.  In spacedeskViewer the primary machine (server) I am trying to connect to is listed, and I've confirmed that it's the correct IP, but when I click on the icon for connection it comes back (after a while) saying "unable to connect".

I have a Wacom tablet (Windows 8.1) as my Primary machine and a Laptop (Windows 10) as the Client.

I have had a previous version of spacedesk working on these machines but haven't used it in a long time and so have started from scratch again.  I uninstalled previous versions of spacedesk from both machines.

I have installed version 0.9.43 on the Primary tablet and version Beta III v0.9.22 on the Client (and confirmed that these are the versions installed).

I have checked the Firewall settings on both machines and had to add spacedeskService to the Laptop. (And have restarted the machine since this).

I am using wifi broadband (no cables) and both devices are connected to this network.

I'm at a loss with what to do next to try and fix the problem.  I cannot manually connect to the tablet (by entering the IP address) because it says it is already listed.

I'm not a technical person so if you need to ask questions please put them in layman's terms.  Many thanks.

 

5 Replies
spacedesk Lea
Posts: 1070
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @donkinc,

What is your firewall software on your primary machine?
Is it the build-in Microsoft Firewall? or a third-party software?

Can you try to ping the IP address of your machines on both sides to check if both are reachable to each other?
Can you try to switch the spacedesk SERVER OFF-ON in the menu button?

Reply
donkinc
Posts: 3
Registered
(@donkinc)
New Member
Joined: 4 weeks ago

Hi Lea, when I search 'Firewall' - on my laptop (client) it says Windows Defender Firewall; on the tablet it just says Windows Firewall.  I have allowed "spacedesk Windows VIEWER" both private and public communication on the laptop and "spacedeskService" the same on the tablet.  I was a bit unsure whether I selected the correct option on the laptop, because I had to go and search for the application.

I don't know how to ping the IP address of my machines.

I have switched the server to status: off, opened the viewer (*) and it says that it cannot detect the primary machine.  I then switched the status to 'on' on the server and the viewer then lists the machine with a connection button.  But when I click on this, after a while it comes back with the same message as before (connection failure: unable to connect).

(*) when I first open the viewer it says that it is "auto-connecting to 1.132.109.142" but I don't recognise this IP so I go to File, Disconnect to stop that process.

 

Reply
spacedesk Lea
Posts: 1070
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @donkinc,
Are you connecting over the wireless network?

To ping the IP address just run Command Prompt (on primary machine), then type "ping <IP address of secondary machine>".
e.g. ping 192.168.1.2

Then do it again the other way around, ping the IP of primary machine on your secondary machine.

To get the IP address of the machine, just type "ipconfig" in the Command Prompt.

Is your current network type on primary machine, public or private?
If it's Public, can you try to change it to Private? 
Please check this link for details.

 

Reply
donkinc
Posts: 3
Registered
(@donkinc)
New Member
Joined: 4 weeks ago

Hi Lea

Yes I am connected over a wireless network - a Telstra wifi modem.

I tried pinging from each machine and they both failed four times.

I had the network set to private on the primary machine when I did the ping test.

I changed the network on the secondary machine to public and now the primary machine can ping the secondary machine.

Can I just check something?  The primary machine is the one whose screen I want to see on the secondary machine.  And I open the spacedesk DRIVER (Server) on the primary machine and then the spacedesk VIEWER on the secondary machine.  I then click on connect to primary machine in the VIEWER.  Is that all correct?

Can I change the network back to public on the primary machine?  I've had a look but can't figure out how to.

Thanks for any help you can offer.

Reply
spacedesk Lea
Posts: 1070
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @donkinc,

Posted by: @donkinc

I changed the network on the secondary machine to public and now the primary machine can ping the secondary machine.

Did you also try the other way around? ping your primary machine from your secondary machine?

Posted by: @donkinc

Can I just check something?  The primary machine is the one whose screen I want to see on the secondary machine.  And I open the spacedesk DRIVER (Server) on the primary machine and then the spacedesk VIEWER on the secondary machine.  I then click on connect to primary machine in the VIEWER.  Is that all correct?

yes that's correct

Posted by: @donkinc

Can I change the network back to public on the primary machine?  I've had a look but can't figure out how to.

yes

Can you quickly try WiFi Direct Connection between your primary and secondary machine?
Just that in this case, you enable the Mobile Hotspot on your Windows 10 laptop (Settings -> Network & Internet -> Mobile hotspot), then connect your Windows 8.1 primary machine wifi on the WiFi Direct network created on your Windows 10 laptop.

Reply

spacedesk forum footer

Copyright © 2020 spacedesk Support Forum