Facebook Like Button

Welcome Visitor! Please Login or Register
Touch Issue with ne...
 
Share:
Notifications
Clear all

Touch Issue with new version (was working in Win_10_64_v0934_BETA.msi)  


sondeu
Posts: 9
Registered
(@sondeu)
Active Member
Joined: 3 weeks ago

Hi,

as you may know a lot of FlightSimmers are using your application for MSFS2020 and we identified an issue with touch support.

With your latest version it is not possible to control flight touch controls (Garmin 3000) from the Flight Simulator. Luckily I had the v0934 on my secondary PC, where it was still working. On the primary with the latest version touch was not possible (or only every 10 times touch).

This is how it should work:

removed link

but does not with your latest version.

Happy to buy the SW when released and very happy for your free beta - but this feature is a "must" and my fear is that it will remain broken.

Would be great if you can investigate and fix. 

 

Cheers & Grüße aus Stuttgart,

Son

18 Replies
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @sondeu,
For further analysis could you please tell us the following details:
- Primary machine operating system (Windows 8.1/10)?
- Secondary machine (Android/iOS/Windows)?

What is the current touch input type on your viewer app (Absolute/Relative)?
Link is not allowed to post due to security issues. What does the link contain? Is it a screenshot?
You can attach it on your reply.
PS: Attach option should be visible on your side after your second post.

Reply
sondeu
Posts: 9
Registered
(@sondeu)
Active Member
Joined: 3 weeks ago

Thank you for your notice Lea,

- so if I talk about Primary and Secondary I mean Server1 and Server2, 2 Windows 10 (latest release and fully updated) machines which were using different versions. While on Server1 running with your latest ServerSW touch is not possible on Server2 running the 934 version Touch is possible. 

It is not issue on the client device, tested with Surface (Win10), Amazon FireHD (Android version) and iPad (iOS). Always the same behaviour. Connected to Server1 - touch in FlightSimulator is not working. Connected to Server 2 (with old Spacedesk SW 934) touch is working very smooth in both FlightSimulator and Windows. 

Link was to a YT Video I did, showing how it should work, but with the latest Update it is not working in MS FlightSimulator. 

Just search for Xgp2bYQkXjk in YT - It is called G3000 Mod by mrtson (me)

 

Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @sondeu,

Thanks for the feedback. We have seen the youtube video.
With the latest spacedesk version v0969, we now have spacedesk virtual HID driver that handles the touch input.
Make sure to also use the latest version of spacedesk Viewer app on your surface, android and iOS device.
It should work now as a real touchscreen (without the mouse pointer) though it's still a single-touch input.
Could you please run devmgmt.msc on your primary machine, click "View" tab then "Devices by connection", scroll down and find "spacedesk virtual HID Device" then check underneath it if there are 3 "HID-complaint touch screen".

Reply
sondeu
Posts: 9
Registered
(@sondeu)
Active Member
Joined: 3 weeks ago

OK, I see this is the problem 🙂 I was reading from others using touch-screens directly connected via HDMI+USB and they have exactly those issues. Microsoft Flight Simulator is not supporting touch (yet?) so it won't work. While with your version supporting the "mouse pointer" seems to make the positive difference in this case. May be you could include an Option for this as "fallback" solution to support also Applications which do not support touch natively? 

Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @sondeu,

You can still use the mouse touch input (like before) just follow the steps below:
- run services.msc on your primary machine
- find spacedeskService and right-click Stop it (temporarily)
- run devmgmt.msc on your primary machine
- click "View" tab "Device by connection"
- find spacedesk virtual HID Device
- underneath the spacedesk virtual HID Device, right-click "disable device" all 3 HID-compliant touch screen
- go back to services.msc and restart the spacedeskService
- try to connect a spacedesk viewer, mouse-touch input should work now instead of touch screen input

Looking forward to your feedback.

Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @sondeu,
By the way, maybe there's a settings in the MSFS to support touch screen? Can you also check it?

Reply
sondeu
Posts: 9
Registered
(@sondeu)
Active Member
Joined: 3 weeks ago

Hey Lea,

 

great support, thanks. It works in the way you described. Thanks a lot. 

Unfortunately MSFS is not yet supporting touch :/

 

Now brings me to another item, performance. While I move part of the games from Screen to the Spacedesk Screen FPS goes down from 50 to 33 (in good circumstances). I assume GPU is taking some power to draw the picture to Spacedesk. Any chance that Spacedesk is not going to use the GPU (in this case RX5700XT) but instead use the power from the integrated graphics adapter on the CPU? It is enabled, driving another monitor there. Or do you have other ideas to improve the performance (of the game on the main screen - I do not mean performance of the spacedesk screen - this is working quiet well).

 

Cheers and stay healthy,

Ralf

Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @sondeu,
Currently, spacedesk cannot select which graphics adapter to use.
spacedesk will always use the primary/main graphics adapter by default, in this case it's your RX5700XT.

Reply
sondeu
Posts: 9
Registered
(@sondeu)
Active Member
Joined: 3 weeks ago

I see. Also looks like it is a problem with ATI and low GPU usage (which is only happening if part of the game is running in Spacedesk screen). Running the game only on the main screen gives 98-99% GPU usage, with Spacedesk it goes down to 30-70 🙁

Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @sondeu,
Is your ATI/AMD graphics driver updated?
Maybe try to update it and check if it helps.
You can download the latest driver version from their website.
https://www.amd.com/en/support

Reply
sondeu
Posts: 9
Registered
(@sondeu)
Active Member
Joined: 3 weeks ago

sure, I've tried several different drivers including the most recent one and the optional. 

Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @sondeu, I see..

By the way, 

Posted by: @sondeu

While I move part of the games from Screen to the Spacedesk Screen FPS goes down from 50 to 33 (in good circumstances).

Is the FPS on viewer settings currently set to 60 fps?

Reply
sondeu
Posts: 9
Registered
(@sondeu)
Active Member
Joined: 3 weeks ago

Tried both, what would you suggest?

 

Here, one util with Spacedesk. 

 

Reply
sondeu
Posts: 9
Registered
(@sondeu)
Active Member
Joined: 3 weeks ago

and here without - no problems. GPU is working fully and FPS are good.

 

Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @sondeu,
Not sure if this can help. Can you quickly check your AMD Radeon Settings -> Graphics -> Advanced -> GPU Workload.
Which one is set at the moment? Graphics? or Compute?
Maybe try both and check if it makes any difference.
Make sure to reconnect spacedesk after switching to other settings there and maybe restart whatever app you are running (maybe your MSFS).

Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Another thing - Which spacedesk viewer are you using at the moment?
Is the spacedesk viewer connected to the server over wifi or wired network?

Reply
sondeu
Registered
(@sondeu)
Joined: 3 weeks ago

Active Member
Posts: 9
Posted by: @spacedesklea

Hi @sondeu,
Not sure if this can help. Can you quickly check your AMD Radeon Settings -> Graphics -> Advanced -> GPU Workload.
Which one is set at the moment? Graphics? or Compute?
Maybe try both and check if it makes any difference.
Make sure to reconnect spacedesk after switching to other settings there and maybe restart whatever app you are running (maybe your MSFS).

This option is not available for me - checking google: "Some Radeon cards might be able to switch to Compute Mode automatically. In that case, there would be no option in the driver menu".

 

- Spacedesk View is connected via Wireless and another one via USB connection (USB Tethering). I have no option to connect it wired, except USB. Oh, I have one Surface - I can check with RJ45 cable. 

 

Which FPS Settings do you suggest to use? I used standard (I think 30?)

 

Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @sondeu,

Posted by: @sondeu

Which FPS Settings do you suggest to use? I used standard (I think 30?)

Can you try 60fps (with your surface connected on wired network)?
With direct wired connection (crossover ethernet), you should configure the IPv4 address of the ethernet adapter manually on both sides.
Please check my post here for reference: https://forum.spacedesk.ph/community/postid/5351/

Reply

spacedesk forum footer

Copyright © 2020 spacedesk Support Forum