Facebook Like Button

Welcome Visitor! Please Login or Register
SpaceDesk Windows V...
 
Share:
Notifications
Clear all

SpaceDesk Windows Viewer "(Not Responding)" gray window upon launch stuck forever, how to fix this?  


Miki800
Posts: 4
Registered
(@miki800)
New Member
Joined: 7 months ago

Since this bug is reproduced by doing the most trivial thing (launching the software)

I guess everybody has it? how do you get it fixed? (was this release even tested?)

I experienced it with an older version so I uninstalled and downloaded a brand new version from the website just right now

it is BETA 0.9.25

but the issue still reproduces, looks like this (as attached):

removed link

4 Replies
spacedesk Lea
Posts: 1299
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @miki800,
Posting link is not allowed due to security issues.
The screenshot you sent shows that the viewer cannot detect your primary machine.
This happens when:
- your primary machine and secondary machine are not connected on the same local area network
- third-party firewall blocks the spacedesk network discovery
- VPN currently active
- etc..
Please also check our troubleshooting - network connection chapter in our user manual.

For further analysis could you please send us the details:
Primary machine
- operating system (Windows 8.1/10)?
- GPU (AMD/Intel/Nvidia)?
- network type (wires/wireless/wifi direct)?

Secondary machine
- network type (wires/wireless/wifi direct)?

Reply
Miki800
Posts: 4
Registered
(@miki800)
New Member
Joined: 7 months ago

ok I agree that some steps may be required to make this work,
but we can both easily agree that gray window, the software being unresponsive, even in the case that primary machine is network-wise unavailable - should never happen, its a real bug.

 

Just to make things clear - I was not able to click on anything moment after the software was launched, nothing.

it became unresponsive immediately, like 0 seconds after launch. I was not able to try and configure the primary machine ip or do anything.

 

Don't you agree its a bug?

Reply
Miki800
Posts: 4
Registered
(@miki800)
New Member
Joined: 7 months ago

(My specs are screenshot in the previous comment's attachment)

 

I just want to add - the chrome browser spacedesk viewer from the client/monitor-machine

is working without any issues at all.

This bug exists only for the spacedesk client/monitor-machine software.

 

Don't you agree that their features / ability to not crash / being able to work

should be identical?

Reply
spacedesk Lea
Posts: 1299
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @miki800,

Thanks for the feedback.
Ah yes, if it's not responding then there's a problem with our native Windows viewer app.
And so far, you are the only user who reported it at the moment.
We are trying to reproduce it here but this issue is not yet happening on our test machines here.
For further analysis, could you please send us the dxdiag info of your secondary machine, just run dxdiag.exe, click "Save All Information" and attach the output file (dxdiag.txt) on your next reply.

 

Posted by: @miki800

Don't you agree that their features / ability to not crash / being able to work

should be identical?

Not completely the same. Our windows viewer app is a Windows native program (C++) that uses Direct3D 10 for rendering the screen, while our HTML5 viewer operates over a web browser and uses HTML5 + javascript for rendering the screen.

You might also try our prototype version of UWP viewer app which is available in the Microsoft Store - this is also a different viewer app.
Then let us know if it works or not.

Reply

spacedesk forum footer

Copyright © 2020 spacedesk Support Forum