Facebook Like Button

Welcome Visitor! Please Login or Register
Spacedesk server (v...
 
Share:
Notifications
Clear all

Spacedesk server (v. 0.9.43) not working (Windows 10) Cannot connect (Connections : 0)  


Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Spacedesk server (v. 0.9.43) not working (Windows 10).

(100 character limit?)

Topic Tags
50 Replies
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

When trying to connect with Android and Viewer (WIN10) (Both latest versions) there are no connections (Connections : 0). The viewers discovers the server and try to connect. After connection there is black screen that says "Connected - Display OFF".

There is no second display available in display settings.

Spacedesk (at least earlier versions) worked in same network environment and nothing is changed there.

I tried also restarting display device in device manager, but this did not help.

The only thing that I found a little strange is that I cannot restart the Spacedesk service in services.msc. It seems to hang in stopping.

My DxDiag.txt attached.

 

Any other tips or ways to debug?

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

It seems that I was not able to attach file earlier...

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

No solution yet but some testing: No error codes that I have seen. Restarted all devices several times. Tried different settings and resolutions.

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Some further checking:

SpacedeskService is running and spacedesk SERVER window shows spacedesk ON status.

No VPN is running at the moment. The VPN I am using did not trouble SpaceDesk earlier, though.

Cheked Windows Firewall that there are private and public access to Spacedesk. No filtered packages appearing when connecting.

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago
Hi @keggi,
Thanks for sending your dxdiag info.
Yes, it seems that the display off issue is caused by a hanging spacedeskService.
As of now we cannot reproduce the same issue on our side, so we will need more info on your side.
Can you tell us the previous working version of spacedesk on your machine before your update to latest v0943?
Does the Display OFF issue immediately happen on first time connect after updating to v0943?

Can you try to open the task manager, find the spacedeskService then try to "End task" it, then after that, try again to resart it on services.msc.
Please let us know if you still get the display off + hanging spacedeskService.
Looking forward to your feedback.
Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Hi Lea! Thanks for the reply.

Unfortunately I do not remember the last working version. I have waited for "couple of version" for new working release. I can test older versions if you have them available.

Issue happens immediately, so I have not had any working connection since.

I have ended task (Task manager) and started it again (services.msc). This works and no errors but the connection does not work.

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago
Hi @keggi,
Thanks for the feedback.
Can you send us the spacedeskSetup.log file located in C:\Users\Public?
If it's not too much to ask, we would like you to provide us a debug traces during this issue.
Please confirm if it's ok for you, then we will send you some instructions on how to get debug traces on my next post.
Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Yes. This is the log and debugging would be ok for me.

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Trying to attach the log.

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Trying to attach the log.

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @keggi,

Thanks for sending the setup log file.

Please follow the steps below on how to get spacedesk server error traces:
1. Download 2019_spacedesk_server_debugging.zip here.
https://www.dropbox.com/s/eo8tol94pzh0u3n/2019_spacedesk_server_debugging.zip?dl=0

2. Extract files from 2019_spacedesk_server_debugging.zip, and in there you will find:
- spacedesk_DebugON.cmd - to enable error trace of spacedesk
- spacedesk_DebugOFF.cmd - to disable error trace of spacedesk
Please right-click the spacedesk_DebugON.cmd and run as administrator on your primary machine.

3. Download a DebugView application which is available here http://live.sysinternals.com/Dbgview.exe

4. Run the Dbgview.exe as administrator on your primary machine.

5. On DebugView Capture tab, make sure to check:
- Capture Win32
- Capture Global Win32
- Capture Events

6. While DebugView is open, run "services.msc" then find spacedeskService then right-click -> Restart. (Or if it's hanging, try to "End task" it on task manager then Start it on services.msc)
You should find spacedesk traces by now on DebugView (e.g "SI: xxx, SE: xxx, SN: xxx, etc").

7. Then try to connect the spacedesk client again (even if it fails to connect).
Please save the logs and send it to us for further analysis.

7. After getting the logs, please disable again the spacedesk traces by running the spacedesk_DebugOFF.cmd, then restart again the spacedeskService in services.msc.

Looking forward to your feedback.

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Here is the log.

Tried to stop --> Hanging
Stop in task manager
Start --> Starts fine (no errors)
Trying to connect (No log lines that I noticed?)
Also couple of restarts...

I did not remove any lines but maybe note if there is any sensitive information so I will remove the file from the forum.

Please let me know If the log is not good and something else is needed!

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @keggi,

Thanks you for sending the log file. We are currently analyzing it.
What is your network connection type between primary and secondary machine?
Is it over the wireless network? Or USB tethering? Or WiFi Direct/Mobile hotspot?

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Wifi. My private wlan and network. Nothing special and as I mentioned the software has worked before.

I forgot to mention that I ran the test with VPN on. I can send you a new log file with VPN off and after restart.

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @keggi,

Thanks for the info.
Yes, please send us a new log file with your VPN OFF.

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Hi Lea,

Here is the log without VPN. Sequence:

Turn service on
Try to connect (issue)
Turn service off (hang)
End task
Turn service on
Try to connect (issue)

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @keggi,

Thanks for sending a new logs.
We noticed that you have a disabled MirrorOp driver on your machine.
Was it installed before with the working old spacedesk version?
Or did you recently installed it?

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Hi! Sorry for delay.

It has been / was installed when the Spacedesk was working earlier.

Same issue persists with and without this driver enabled. I tried to disable this for testing purposes, but it was no help.

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @keggi,

Thanks for the info.
We will continue analyzing the issue and get back to you as soon as we have a potential fix for the hanging spacedeskService.

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Dear Lea,

I tried to install v0.9.44.

It was interesting that I was able co make connection after install (Connections 1) but there was no picture or display available in (Win10) settings.

After restart I was not able to connect again (Connections 0).

Still waiting for any ideas...

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

To add to last: I am still not able to restart the SpacedeskService without hang.

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @keggi,
Can you tell us your android device's info (e.g. brand, android version, native screen resolution)?
Can you also quickly try to connect using spacedesk HTML5 Viewer?
Just open a web browser on your android device (e.g. Google Chrome) then go to http://viewer.spacedesk.net/ then try to connect to your PC's IP address. Then let us know if you still get the same issue.

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Hi!

I have tried with several android devices: Samsung Galaxy Tab Pro 12, Samsung Galaxy Tab S10.5, Oneplus 6T.

No connection with HTML5 viewer either. 

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

I tried also with second Win10 device (complete different setup and hardware) with the same results.

If you have any tips with the network I am able to try to tweak somethins...

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @keggi,
Can you please try our most recent spacedesk v0.9.48 on our website?
Then let us know if this version improved.

Looking forward to your feedback.

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Hi Lea,

I tried version v0.9.49. No help.

Before reboot I had a little bit different result, when the app said 1 connection and "ERROR" and there was ERROR on the same menu as ON/OFF.

Still after reboot same problem and there is zero Connections.

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @keggi,
Thank you very much for the feedback.
We will get back to you when we have new version for you to try.

In the meantime, could you please download the 2020_spacedeskDiagnosticTool.zip file here then extract it.
Inside you will find spacedeskDiagnosticTool.cmd, just right-click it then run as administrator.
This script will start a debug view app to capture spacedesk debug traces.
On step 5 it will prompt you to reproduce the issue, make sure to do this before pressing any key to continue.

This new diagnostic script will easily provide us the needed server traces and driver logs.

After the script is done, a folder will be created on the same folder as the script file which contains various log files that we need for analysis.
Please right-click it -> Send to -> Compressed (zipped) folder, then attach the *.zip file on your next reply.
Looking forward to your feedback.

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Hi!

Tried with the new version 0.9.53. No luck!

Here are the logs.

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Hi,

Here are also followings steps:

1. Try to connect

2. Try to sop service (hang)

3. End task (taskmanager)

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago
Hi @keggi,
Thanks for the feedback.
Can you quickly try the following steps:
- Run services.msc, find spacedeskService and Stop it.
- Go to C:\Windows\System32 and delete the following binaries/files:
  -- spacedeskKtm.dll
  -- spacedeskServiceTray.exe
  -- spacedeskSrvLibConnectorUsb.dll
- Restart the spacedeskService in services.
- Try to connect again, and check if the issue still persist.

If issue still persist, please run the v0953 installer then repair to bring back the removed binaries.
Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Hi Lea,

Thanks for support!

Deleting those files and restarting the service (+boot) did not help with the issue.

Br, Anssi

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @keggi,

We have released a new spacedesk driver v0959 on our website
Can you please quickly try it and check if the hanging service is still reproducible?

Posted by: @keggi

Unfortunately I do not remember the last working version. I have waited for "couple of version" for new working release. I can test older versions if you have them available.

 
If problem still persist on latest version, I would like to track down on which version it was introduced.
Please download these 2 older msi here: https://www.dropbox.com/s/2rlnxp0qxgrykli/old_version_0934-37.zip?dl=0
It contains v0934 and v0937 MSIs please check both version if the same issue is also happening.
Looking forward to your feedback.

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Thanks for your help!

Unfortunately both of these old versions produce same results: App says connected but the driver says Connections: 0. Also no displays available in settings.

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @keggi,
Thanks for quickly trying it.
Did you also check our latest released version 0959 on our website?

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Sorry about the delay! I have a little promising news (on version 0959)!

I managed to get the connection briefly working in the phone (OnePlus6) by sharing the wifi network to the computer from the phone (tethering). This was a brief success since after successful try the Taskbar server application (windows 10) reports ERROR. Since the connection does not start again.

It seems that this may be somehow network settings related on server computer (Windows 10), since I do not think I have any restrictions on the other network and wifi (on my ASUS router).

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

I am not sure what is the difference between these networks. In tethering spacedesk is working and in wifi (Asus router) it is not workin. 🙁

Here are the diagnostic files for both success and failure with new version 0961.

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @keggi,
Thank you very much for the feedback and sending your latest diagnostic files.

Posted by: @keggi

I managed to get the connection briefly working in the phone (OnePlus6) by sharing the wifi network to the computer from the phone (tethering). This was a brief success since after successful try the Taskbar server application (windows 10) reports ERROR. Since the connection does not start again.

Is this still happening?
Did you see the error notification?
Is it also showing ERROR in the server status of the spacedesk tray app window? If yes, can you easily switch it to ON?

Posted by: @keggi

in wifi (Asus router) it is not workin

Maybe there's a setting in your router that causes the hang.

Reply
Keggi
Registered
(@keggi)
Joined: 4 months ago

Trusted Member
Posts: 30
Posted by: @spacedesklea

Hi @keggi,
Thank you very much for the feedback and sending your latest diagnostic files.

Posted by: @keggi

I managed to get the connection briefly working in the phone (OnePlus6) by sharing the wifi network to the computer from the phone (tethering). This was a brief success since after successful try the Taskbar server application (windows 10) reports ERROR. Since the connection does not start again.

Is this still happening?
Did you see the error notification?
Is it also showing ERROR in the server status of the spacedesk tray app window? If yes, can you easily switch it to ON?

No more ERRORs when tethering. It is working solid.

Posted by: @keggi

in wifi (Asus router) it is not workin

Maybe there's a setting in your router that causes the hang.

I am wondering what could it be? I tried disabling firewall and tried to set both networks as private. There should be nothing restricting in my router and the devices are definitely "seeing each other" before the connection...

Reply
jmichaelkramer
Posts: 5
Registered
(@jmichaelkramer)
Active Member
Joined: 4 weeks ago

Overnight, my two android tablets that will no longer connect and function as secondary monitors.  Tested also with well as a windows 10 client and Chrome.  Same result.  "connected - Display off" . Server shows no connections. Laptop is Lenovo t490.  They will connect to my personal PC which is windows 10.

Turning off firewall, rebooting, does not work. IS deployed the older version to my machine 9.34 and client is 9.61.  Not sure what changed.   

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @jmichaelkramer,

Please make sure that your spacedeskService is running and can be restarted easily/properly.
Run services.msc, find spacedeskService and try to restart it, if it's not hanging then please proceed as instructed below.
If it cannot stop the spacedeskService easily, please run the task manager, find spacedeskService.exe and "End task" it. Then restart it on services.msc, and proceed to the instructions below.

To further analyze this issue, please download the spacedesk diagnostic script here, then extract it.
https://www.dropbox.com/s/ilm5em35h0ygsfm/2020_spacedeskDiagnosticTool.zip?dl=0

Inside you will find spacedeskDiagnosticTool.cmd, just right-click it then run as administrator.
This script will start a debug view app to capture spacedesk debug traces.
On step 5 it will prompt you to reproduce the issue (by connecting the viewer app that shows display off status), make sure to do this before pressing any key to continue.
After the script is done, a folder will be created on the same folder as the script file which contains various log files that we need for analysis.
Please right-click it -> Send to -> Compressed (zipped) folder, then attach the *.zip file on your next reply.

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Dear @spacedesklea,

Thanks for all your help!

It seems that changing IP address of my server computer (Windows 10) has solved my problem somehow!

Namely I had previously 198.168.1.3 and but changin it to something else (namely 198.168.1.43) seems to have solved the hang. I think it is hard to tell where the problem was but this seem to be the solution in my case.

Hopefully this helps your development somehow!

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @keggi,
How did you change the IP address?
Is it the IP address of your WiFi Adapter?

So now, there's no more hang when connecting over the wireless network?
This is really a very strange issue.

Reply
Keggi
Registered
(@keggi)
Joined: 4 months ago

Trusted Member
Posts: 30
Hi @spacedesklea,
Posted by: @spacedesklea

How did you change the IP address? Is it the IP address of your WiFi Adapter?

I changes the IP (of my Windows 10 Spacedesc Server computer) in my wifi (LAN) by forcing a new DHCP lease.

So now, there's no more hang when connecting over the wireless network?
This is really a very strange issue.

It is and I dont see any obvious reason why this was happening. It is working now and I think nothing else has changed. It also worked instantly after the renewal of IP lease (no reboots or anything).

Reply
jmichaelkramer
Posts: 5
Registered
(@jmichaelkramer)
Active Member
Joined: 4 weeks ago

I fixed it.

Notes for troubleshooting.  It looks like my laptop connected to 5g and the tablet was on 2G.  Same router so should not have been a problem.  I use a Linksys router.  Once they were both on the same frequency it worked fine.  I suspect this is idiosyncratic and others will not have the same problem

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Hi @spacedesklea,

Forget my earlier comment about IP. Actually changing IP was not the solution.
 
The solution for me was connecting 2G wifi with my Windows 10 server. It is working although my tablet is in 5G. This may be something that you could test on Windows 10?
 
Thanks to jmichaelkramer for inspiration.
Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @jmichaelkramer Hi @keggi

Thanks for the input.
We will check and try to reproduce it with different frequency.

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago

Hi @spacedesklea,

Any luck in reproducing the error on 5G wifi? On my Windows 10 the error still persist on 9.64.

It is a bit annoying to switch to 2G since it is a bit slow.

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @keggi,
Unfortunately, we still cannot reproduce it on our side.
We have 5Ghz and 2.4Ghz wifi here and connecting our machines on each of them works.
But we are still continuously trying on different machines and setups.

Can you quickly try our recent spacedesk Driver v0964 on our website and check again.
Then let us know the result if your server is connected on 5Ghz and your client is connected on 2.4Ghz. Does the spacedeskService still hangs upon connect?

Reply
Keggi
Posts: 30
Registered
(@keggi)
Trusted Member
Joined: 4 months ago
Posted by: @spacedesklea

Can you quickly try our recent spacedesk Driver v0964 on our website and check again.
Then let us know the result if your server is connected on 5Ghz and your client is connected on 2.4Ghz. Does the spacedeskService still hangs upon connect?

I'll be damned! It is actually working when server on 5G and client on 2.4G! This gives some speed and seems to be sufficient!

Strange, but I am beginning to believe that this problem is because of my router: ASUS RT-AC87U with firmware asus-merlin 384.13_1.

Thanks again! 

Reply
spacedesk Lea
Posts: 1280
Moderator
(@spacedesklea)
Illustrious Member
Joined: 1 year ago

Hi @keggi,
Thanks for the feedback.
Strange indeed. Our latest v0.9.64 only has bug fix for a certain disconnect bug.
Maybe you are right, maybe the problem has something to do with your router.

Reply

spacedesk forum footer

Copyright © 2020 spacedesk Support Forum