Facebook Like Button

Welcome Visitor! Please Login or Register
Spacedesk server di...
 
Share:
Notifications
Clear all

Spacedesk server disconnected randomly  


ductrinh1810
Posts: 7
Registered
(@ductrinh1810)
Active Member
Joined: 1 month ago

Hi There,

 

I'm getting in trouble with the disconnected randomly between 1-5 hours of using problem when connect 2 clients android device as expand monitors

My setup:

  • Spacedesk server: windows 10 professional 20H2, VGA NVIDIA RTX 3090 (no ShadowPlay, no in game overlay) with latest NVIDIA driver 466.27. CPU Intel 10900k , 64GB DDR4 RAM. Spacedesk server latest version 0.9.95
  • Spacedesk client: 2 x Android tablet (android version 8.1) with spacedesk client version 0.9.67
  • Connection type: LAN wired connection 1Gbps with router draytek vigor 2925
  • Firewall: allowed spacedeskservice for both inbound and outbound rules.

Thanks

Duc Trinh

14 Replies
ductrinh1810
Posts: 7
Registered
(@ductrinh1810)
Active Member
Joined: 1 month ago

Any one can help with this problem ?

Reply
spacedesk Lea
Posts: 2583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @ductrinh1810,
It's possible that it's a temporary network connection drop that's causing the sudden disconnect.

When it disconnects, did your viewer apps shows the disconnect message box?
If yes, can you maybe try to enable the auto-reconnect option in the viewer settings?
And check if it helps with the random disconnect.

Reply
ductrinh1810
Posts: 7
Registered
(@ductrinh1810)
Active Member
Joined: 1 month ago

The viewer app didn't show any messages about disconnected, it's just quit my pc desktop and show the list of ip for connecting. Sometime it crashed the viewer app

Reply
ductrinh1810
Posts: 7
Registered
(@ductrinh1810)
Active Member
Joined: 1 month ago

The viewer app didn't show any messages about disconnected, it's just quit my pc desktop and show the list of ip for connecting. Sometime it crashed the viewer app

Reply
spacedesk Lea
Posts: 2583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @ductrinh1810,
Did you try to enable the auto-reconnect and see if it helps?

Posted by: @ductrinh1810

Sometime it crashed the viewer app

this is android viewer, right?

Reply
ductrinh1810
Posts: 7
Registered
(@ductrinh1810)
Active Member
Joined: 1 month ago
Posted by: @spacedesklea

this is android viewer, right?

Yes it is

 

Posted by: @spacedesklea

Did you try to enable the auto-reconnect and see if it helps?

I enabled the auto-reconnect already but the problem is still there.

 

PS: I just tried to change the quality configuration to the new setting below and there is no disconnected problem for 22 hours of usage, so weird.

  • Quality is set to about 75% of the slider (previous is 50%).
  • Encoding Color Depth to "High color quality, slow speed (YUV 4.4.4)" (previous is Medium color quality, medium speed (YUV 4.2.2))
  • Rendering Color Depth "24-bit (RGB 888)" (no changed)

 

Reply
spacedesk Lea
Posts: 2583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

I see.. thanks for the info.
We will check if the issue is related to this quality/encoding settings. 

Reply
ductrinh1810
Posts: 7
Registered
(@ductrinh1810)
Active Member
Joined: 1 month ago

Hope you will find a solution soon. Thanks

Reply
zoghal
Posts: 2
Registered
(@zoghal)
New Member
Joined: 1 month ago

hi

I had exactly the same problem.
I applied these settings and my problem was solved.

PS: I just tried to change the quality configuration to the new setting below and there is no disconnected problem for 22 hours of usage, so weird.
- Quality is set to about 75% of the slider (previous is 50%).
- Encoding Color Depth to "High color quality, slow speed (YUV 4.4.4)" (previous is Medium color quality, medium speed (YUV 4.2.2))
- Rendering Color Depth "24-bit (RGB 888)" (no changed)

Reply
spacedesk Lea
Posts: 2583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @zoghal and @ductrinh1810,
Does the random disconnect with this specific settings only happens while there's a continuous updates on the viewer screen?
Or does it also disconnect even if there's no activity in the viewer screen?

Reply
zoghal
Registered
(@zoghal)
Joined: 1 month ago

New Member
Posts: 2
Posted by: @spacedesklea

Hi @zoghal and @ductrinh1810,
Does the random disconnect with this specific settings only happens while there's a continuous updates on the viewer screen?
Or does it also disconnect even if there's no activity in the viewer screen?

If there is no activity on the viewer page, it will be disconnected after 5-10 minutes,But if there is activity on the viewer page, it will disconnected after 30-60 minutes

Of course, I did not do a number of tests for more time

Reply
Blu_Ray
Posts: 1
Registered
(@blu_ray)
New Member
Joined: 1 month ago

hi

I had exactly the same problem today too, but I applied these settings and my problem is not solved... I'm using any settings and this happens.
I am an iPad 7 user on the latest version of iOS 14 and Spacedesk Windows Server on 0.9.97, and I noticed the missing option of change the rendering color depth in the client app settings on the iPad for an unknown reason, so maybe there is a problem ? in color depth rendering ?

@spacedesklea It makes no difference, it happens when I have a static image of e.g. Word text or I am watching a movie 🙁

Oddly enough, sometimes I have to turn off and on the wi fi on the iPad, as if the icon shows the connection, but the space desk client app does not see my computer until I restart not only the app, but the wi fi.

Reply
ductrinh1810
Posts: 7
Registered
(@ductrinh1810)
Active Member
Joined: 1 month ago

Hi all,

My problem was solved and I could use 2-3 days and the problem came again. After that I switched to use wall display instead of multiple the monitor. The problem is solved again for 5 days up to now.

 

Regards,

Duc Trinh

Reply
spacedesk Lea
Posts: 2583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @blu_ray,
Is it iOS 14.5.1 (to be exact)?
How long it takes before it disconnects?
Can you also send us the screenshot of your spacedesk iOS viewer's quality settings, showing the missing option for color depth?

PS: Attach option should be visible on your side on your third post.

Reply

spacedesk forum footer

Copyright © 2020 spacedesk Support Forum