Facebook Like Button

FYI: This old forum site will not be updated anymore. To post a new topic, please click here to register to our new spacedesk Forum site.
Spacedesk dose not ...
 
Share:
Notifications
Clear all

[Solved] Spacedesk dose not work on Win 10 64bit?  


sunnyboy0030
Posts: 9
Registered
(@sunnyboy0030)
Active Member
Joined: 6 months ago

My primary machine has GTX1070 and two physical monitors with windows 10 64bit pro os and spacedesk v0.9.82 installed. The second screen is sony Z4 tablet. The primary machine can be found on Z4 tablet but both screen of tablet and primary machine will be blacked out after hit the machine IP. A message showing on the tablet says: Connected - Display Off. After several seconds, an error will be displayed on the tablet showing Error Code: 2-5 and Error Info: 0-5. The primary machine can not response to ctrl-alt-del. The only way to restart the machine is to press the reset button. I did the DXdiag and Spacedeskdiag but can not find the way to attach these files. Please help.

Topic Tags
14 Replies
sunnyboy0030
Posts: 9
Registered
(@sunnyboy0030)
Active Member
Joined: 6 months ago

How to attach a zip file?

Reply
sunnyboy0030
Posts: 9
Registered
(@sunnyboy0030)
Active Member
Joined: 6 months ago

The diagnostic file please refer to the attachment.

Reply
spacedesk Lea
Posts: 2724
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @sunnyboy0030,
Thanks for sending the diagnostic logs.

Could you also try to click the spacedesk tray icon in the notification area to open the spacedesk SERVER window, then click the menu "..." button and click the "Clear All Display Settings", then try again to connect.

By the way, what is the connection time below the error code on your viewer app?

Reply
sunnyboy0030
Posts: 9
Registered
(@sunnyboy0030)
Active Member
Joined: 6 months ago

Thanks for your rapid reply. I've tried to clear all the settings, but the problem was still there. The time shown below the error info is 10~14s.

Reply
spacedesk Lea
Posts: 2724
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @sunnyboy0030,
Do you maybe have Nvidia ShadowPlay / screen recording / Instant replay currently running on your primary machine?
If yes, please disable it before connecting a spacedesk viewer.

 

Reply
sunnyboy0030
Posts: 9
Registered
(@sunnyboy0030)
Active Member
Joined: 6 months ago

I've disable the In-Game Overlay in Geforce Experience already, so this is not a case.

Reply
spacedesk Lea
Posts: 2724
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @sunnyboy0030,
We are currently analyzing the log files, do you have VNC Mirror driver currently running on your machine?
If yes, can you try to switch it OFF then try to connect the spacedesk viewer.

Reply
spacedesk Lea
Posts: 2724
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @sunnyboy0030,

Follow-up questions:
Did you recently update from Windows 7 to Windows 10 operating system?
If yes, was spacedesk already present before on your Windows 7?

Could you please also try the following and let us know the result:
- run command prompt as administrator
- type the command =>  sc query spacedeskHookKmode
- check if the result shows "service does not exist" or if it's there and status shows "Running" or "Stopped".

Reply
sunnyboy0030
Posts: 9
Registered
(@sunnyboy0030)
Active Member
Joined: 6 months ago

Yes, I've updated the OS from Win 7 to Win 10 almost one year ago. For the sc query result please refer to the attachment. The service status is Running.

I also uninstalled the VNC and deleted the VNC mirror drive, the only display adapter is GTX 1070, but the problem still exists.

Reply
sunnyboy0030
Posts: 9
Registered
(@sunnyboy0030)
Active Member
Joined: 6 months ago

The spacedesk worked on previous windows 7 systems.

Reply
sunnyboy0030
Posts: 9
Registered
(@sunnyboy0030)
Active Member
Joined: 6 months ago

Yes, the spacedesk works on previous windows 7 systems quite well.

Reply
spacedesk Lea
Posts: 2724
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @sunnyboy0030,
Thank you very much for verifying.
It seems that the old driver was not removed and continue to run after your Windows 10 upgrade.
Our old spacedesk Windows 7 driver (spacedeskHookKmode) should not be there and this causes the problem in the current spacedesk Windows 10 driver (spacedesk Graphics Adapter).

Could you please try to run Command Prompt as Administrator, then type the command: sc delete spacedeskHookKmode ,then reboot your primary machine.
After that, try to connect again the spacedesk viewer app it should work now.

Looking forward to your feedback.

 

Reply
sunnyboy0030
Posts: 9
Registered
(@sunnyboy0030)
Active Member
Joined: 6 months ago

Hi Lea,

Thank you for your effective solution. After running the sc delete spacedeskHookKmode command and rebooting, the spacedesk works again. Thanks a lot!

Reply
spacedesk Lea
Posts: 2724
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @sunnyboy0030,
Thanks for the feedback.
We are glad to hear that spacedesk is now working on your side.
In case you encounter other issues, just let us know.

Reply

spacedesk forum footer

Copyright © 2020 spacedesk Support Forum