Facebook Like Button

Welcome Visitor! Please Login or Register
sleep viewer machin...
 

sleep viewer machine, wake, no reconnect  


sjpt
Posts: 2
 sjpt
Registered
(@sjpt)
New Member
Joined: 2 weeks ago

Very helpful program, thank you.

When I sleep the viewer machine it disconnects (fair enough).  However, when I wake the viewer machine it does not automatically reconnect.

I need two interactions on the viewer; one to dismiss the 'Disconnected Manually' dialog, and another to remake the connection.  The second is not easily navigated to with tabs key etc but (as far as I can see) requires the mouse removed link ; This is not a major problem, but a repeated irritation.  The trackpad is awkward to get to and I have a thumb opposition problem that makes it awkward even when easily within reach.

Settings, Automatically Connect are appropriately set up; they work after exiting and restarting the viewer, or sleeping and reawakening the server.

Both machines Win10, wired network.

~~~

p.s. even better would be a feature that put the viewer machine to sleep when the server went to sleep, and reawoke the viewer with wake-on-lan when the server was woken up.

 

Topic Tags
2 Replies
spacedesk Lea
Posts: 171
Moderator
(@spacedesklea)
Prominent Member
Joined: 4 months ago
Hi @sjpt,

Current spacedesk Windows viewer is designed to manually disconnect upon client machine system sleep (even if auto-reconnect is enabled).
That's how we handle it at the moment but we are open to change it in the future.

As for the trackpad problem, is your client machine monitor touch screen? Is it surface tablet?
Does the trackpad/relative touch feature requires to also check the Functionality -> Mouse?
 
Posted by: @sjpt

p.s. even better would be a feature that put the viewer machine to sleep when the server went to sleep, and reawoke the viewer with wake-on-lan when the server was woken up.

We think that's not possible OR (if possible) very difficult to implement.
This involves remote power management. When the client machine goes to system sleep, its network is also in sleep and won't be able to receive the packet or signal from the server machine upon power resume (wake-up).
 

Reply
sjpt
Posts: 2
 sjpt
Registered
(@sjpt)
New Member
Joined: 2 weeks ago

Thanks.  The main issue is the first one, not the wake-on-lan addition, so please don't forget the main part just because the extra part might be difficult.

Even the second shouldn't be too hard (but could well be ruled out by law of diminishing returns).  The remote power management is a standard part of the OS (Windows at least).  You might want to advise users they need to enable it (eg via device manager, network adaptor settings) for that feature to work, rather than trying to manage it yourself.  See TeamViewer for example: <a href=" removed link "> removed link

Reply

spacedesk forum footer

Copyright © 2019 spacedesk Support Forum

 

  
Working

Please Login or Register