Facebook Like Button

Welcome Visitor! Please Login or Register
Remote Keyboard & T...
 
Share:
Notifications
Clear all

[Solved] Remote Keyboard & Touch doesn't work on Lenovo X1 Carbon G3  


martin.szugat
Posts: 9
Registered
(@martin-szugat)
Active Member
Joined: 3 weeks ago

I'm using SpaceDesk on Windows 10 with the following setting:

Server: Lenovo Yoga A940

Viewer: Lenovo X1 Carbon G3

I've activated keyboard & touchpoint control on the viewer but it doesn't work: when I activate remote and then type something on the X1 there is no input on the server.

Thanks for your help!

Martin

9 Replies
martin.szugat
Posts: 9
Registered
(@martin-szugat)
Active Member
Joined: 3 weeks ago

PS: I've tried both the Windows 10 and Windows 7 viewer version.

Reply
spacedesk Lea
Posts: 1883
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @martin-szugat,

To further analyze this issue, please download the spacedesk diagnostic script here, then extract it.
https://www.dropbox.com/s/ilm5em35h0ygsfm/2020_spacedeskDiagnosticTool.zip?dl=0

Inside you will find spacedeskDiagnosticTool.cmd, just right-click it then run as administrator.
This script will start a debug view app to capture spacedesk debug traces.
On step 5 it will prompt you to reproduce the issue (by connecting the viewer app and try to activate the remote keyboard/touch for several times), make sure to do this before pressing any key to continue.
After the script is done, a folder will be created on the same folder as the script file which contains various log files that we need for analysis.
Please right-click it -> Send to -> Compressed (zipped) folder, then attach the *.zip file on your next reply.

 

Reply
martin.szugat
Posts: 9
Registered
(@martin-szugat)
Active Member
Joined: 3 weeks ago

Hi Lea,

I've executed the cmd file on the server - that's correct? It told me I'm running the wrong version. Maybe this is because on the server I'm running the Windows 10 version but as a viewer the older Windows 8 version because of the missing auto connect feature of the Windows 10 version (see other post).

 

Best, Martin

Reply
spacedesk Lea
Posts: 1883
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @martin-szugat,
Are you using the most recent spacedesk Driver and Viewer version?
Since Auto-connect is not yet available on spacedesk UWP Viewer app (for Windows 10), are you using the spacedesk Windows viewer app for Windows 7 (v0.9.30)?
If yes, then it should still be good, both can still be used to connect with spacedesk server/driver v0.9.78.

Can you send us the screen shot of this:

Posted by: @martin-szugat

It told me I'm running the wrong version.

 

Reply
martin.szugat
Posts: 9
Registered
(@martin-szugat)
Active Member
Joined: 3 weeks ago

Hi Lea,

I've attached screenshots showing the versions of driver and viewer and also of the error message as well as the log files.

Best,

Martin

Reply
spacedesk Lea
Posts: 1883
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @martin-szugat,
Thanks for sending the requested file.

Can you try to enable the auto-reconnect on your viewer app, then try again with the connection.
This error notification will pop-up sometimes but spacedesk can still connect.
We haven't handled this error message correctly with our current spacedesk version.

Can you also quickly check if you can still try to enable the remote keyboard input by re-activating it for a few times (e.g. take control -> ALT+SHIFT try for 2-3 times), sometimes it doesn't work on first try but after a few times of sending keyboard input it will eventually work.

Another possible reason for keyboard and absolute touch not working is if videowall mode is enabled.
Did you enable the videowall mode?
If it's enabled, please disable it then try again with keyboard/touch input.

And if it really doesn't work, please try again to run the diagnostic cmd file then try to reproduce the issue and send us the needed spacedesk debug logs for further analysis.

Reply
martin.szugat
Posts: 9
Registered
(@martin-szugat)
Active Member
Joined: 3 weeks ago

Hi Lea,

thanks again!

It was the video wall: I enabled it because I've another computer I'm using for the teleprompter and so I enabled the video wall to flip the display ... so there is no chance to have keyboad remote control and video wall at the same time?

Best,

Martin

Reply
spacedesk Lea
Posts: 1883
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @martin-szugat,

Thanks for confirmation.
It's possible (in the future version) but will not be available anytime soon.
We are currently very busy with higher prioritized features and bug fixes.
If this becomes available, we will let you know.

Reply
martin.szugat
Posts: 9
Registered
(@martin-szugat)
Active Member
Joined: 3 weeks ago

OK, thanks a lot!

Reply

spacedesk forum footer

Copyright © 2020 spacedesk Support Forum