Facebook Like Button

Welcome Visitor! Please Login or Register
Multiple USB Connec...
 
Share:
Notifications
Clear all

Multiple USB Connections?  


Spacedogg
Posts: 2
Registered
(@spacedogg)
New Member
Joined: 1 month ago

Hey guys I must admit at first I was not liking the lag on the wifi option but now on USB connection this is amazing with zero lag!! Well done 

my question is I just tried to connect a 2nd display using USB and keep my iPad already connected with USBc but the 2nd additional display would not find host until I disconnected iPad then it was all good. Is it possible to connect more than one device via USB? Cheers 

3 Replies
spacedesk Lea
Posts: 1583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @spacedogg,
We never tried with multiple USB tethering connection in one machine and we cannot check here at the moment due to limited resources.

But this is probably has something to do with the Network adapter priority of your windows primary machine.
We have similar case here: https://forum.spacedesk.ph/community/postid/4472/

Maybe you can try to set the metric value of the second USB tethering network.

Looking forward to your feedback.

Reply
Spacedogg
Posts: 2
Registered
(@spacedogg)
New Member
Joined: 1 month ago

Thanks Lea, 

im thinking this just prioritises the order or determines which connection option Windows uses and am unsure if this will allow both connections at once ?

either way I’ll keep messing around with it and hopefully someone who has done this can assist.

 

thanks again 

Reply
spacedesk Lea
Posts: 1583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @spacedogg,
Yes, I think it's about network adapter priority of Windows.

Did you try setting the metric value of the second Remote NDIS network adapter (USB tethering network) manually?
- Just run ncpa.cpl
- In there you will find the 2 Remote NDIS Network Adapter (USB tethering network). Just right-click the second one then click Properties, click on Internet Protocol Version 4 (TCP/IPv4) -> Properties -> Advanced
- Uncheck the "Automatic metric" and set the value to any value(e.g. 3), then click OK to finish it.
- Then check on your second viewer app if it can discover now the primary machine.

Reply

spacedesk forum footer

Copyright © 2020 spacedesk Support Forum