Facebook Like Button

Welcome Visitor! Please Login or Register
[HTML5Viewer] "Coul...
 

[HTML5Viewer] "Could not create Websocket" even though Websockets appear to work  


Fivefold
Posts: 4
Registered
(@fivefold)
New Member
Joined: 5 months ago

Unfortunately the HTML5Viewer won't let me connect with the message: "Could not create Websocket". I tried <a href=" removed link " target="true">websocketstest.com, as stated in the manual and according to it Websockets should work (results: <a href=" removed link " target="true">websocketstest.com/result/17233276 ).

This is on a Lubuntu 19.04 (64-bit) machine and Chromium 73.0.3683.103

It works fine on a different machine using Ubuntu Mate 18.04 LTS and Chromium in nearly the same version.

 

Any ideas?

7 Replies
spacedesk Lea
Posts: 270
Moderator
(@spacedesklea)
Noble Member
Joined: 6 months ago
Please check on the address bar of your web browser if it's blocking unsecure contents in our spacedesk HTML5 page.
If you find it, please unblock it for now. Our current HTML5 page is currently not using SSL certificate so on some web browser it's blocking some of its contents and functionality.
 
Reply
Fivefold
Posts: 4
Registered
(@fivefold)
New Member
Joined: 5 months ago

Hello @spacedesklea

it does warn me that the connection is not secure but javascript is/was allowed. Just in case I put every possible setting on allow. No change in behaviour, unfortunately.

Reply
spacedesk Lea
Posts: 270
Moderator
(@spacedesklea)
Noble Member
Joined: 6 months ago
Thank you for the feedback.
I tried to reproduce here on my side with the same Lubunutu version 19.04 (64-bit) and Chromium browser version 73.0.3683.103 but it's working on my side.
Can you maybe try on other web browser (e.g. Opera)?
Reply
Fivefold
Posts: 4
Registered
(@fivefold)
New Member
Joined: 5 months ago

@spacedesklea That's interesting, since my Lubuntu is fresh out of the box. I only installed Chromium. Tried it with Opera and it's the same thing. Javascript is enabled.

I tried to find a setting which maybe blocks it because of the missing SSL certificate but only found "Protect me from malicious sites". I turned it off with no effect.
Should I try reinstalling Lubuntu?

I don't think it has any relevance but the machine I am trying to connect to is using the windows primary/server client

Reply
spacedesk Lea
Posts: 270
Moderator
(@spacedesklea)
Noble Member
Joined: 6 months ago
Could you please check the attached screenshot if you have the same icon with red x on the address bar of your browser. If you have it, please click it and then click the "Load unsafe scripts".
Reply
Fivefold
Posts: 4
Registered
(@fivefold)
New Member
Joined: 5 months ago

@spacedesklea Unfortunately I don't have that icon. Check my attached screenshot.

Maybe  there is some setting in which is automatically blocking the "unsafe script" in the background without even showing me? The only thing (aside from explicitly allowing javascript) I found was "Safe Browsing", but turning it off does not change anything.

Reply
spacedesk Lea
Posts: 270
Moderator
(@spacedesklea)
Noble Member
Joined: 6 months ago

Hi @fivefold
thank you for the feedback.
We will continue investigating it and will get back to you as soon as we have any news regarding this issue.

Reply

spacedesk forum footer

Copyright © 2019 spacedesk Support Forum

 

Please Login or Register