Facebook Like Button

Welcome Visitor! Please Login or Register
Display Connected b...
 
Share:
Notifications
Clear all

Display Connected but black Screen and Display off  


Xude
Posts: 1
 Xude
Registered
(@xude)
New Member
Joined: 1 year ago

Every time I press on the ip to connect my 2nd device to blackscreen and there is display off.

 

24 Replies
ricardojo2008
Registered
(@ricardojo2008)
Joined: 5 months ago

New Member
Posts: 3
Posted by: @xude

Every time I press on the ip to connect my 2nd device to blackscreen and there is display off.

 

Hello, la solución esta en el siguiente video: removed link

 

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago
Hi @xude,
Have you done any user account switching or remote desktop connection before using spacedesk?
Could you please run services.msc on your primary machine, find spacedeskService then right-click restart it.
Then try to connect again with spacedesk viewer.
If problem still persist, please send us the following for further analysis:
- run dxdiag.exe on primary machine, click "Save All Information" then save the output file (dxdiag.txt)
- all *.etl files on C:\Users\Public\spacedesk_logs folder
Please save all the requested file in one folder, right-click then Send to -> Compressed (zipped) folder, then attach the zip file on your next reply.
Looking forward to your feedback.
Reply
kdspeaks
Posts: 2
Registered
(@kdspeaks)
New Member
Joined: 1 year ago

I am having the same issue.

Reply
ricardojo2008
Registered
(@ricardojo2008)
Joined: 5 months ago

New Member
Posts: 3
Publicado por: @kdspeaks

Estoy teniendo el mismo problema.

Hola, la solución esta en el siguiente video: removed link

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago
If it shows "Dispay OFF" on your side, please check the display settings window on your primary machine if you can find a detached display. If it's there, please just attach it by selecting Extend or Duplicate (there's a multiple displays dropdown menu box below).
 
Reply
Stoubar
Posts: 1
Registered
(@stoubar)
New Member
Joined: 9 months ago

Hi,

I having some problem like this, but i cant find the other monitor, my pc just don't find the second monitor, but my smartphone have black screen with "Connected - Display Off". How can i solve this?

Smartphone: Samsung Galaxy S7 Edge (Android 8.0)

PC: Dell G3 3590 (i5 9300H + GTX 1650) with windows 10 with update 2004

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @stoubar,

To further analyze the problem could you please download the 2020_spacedeskDiagnosticTool.zip file here then extract it.

Inside you will find spacedeskDiagnosticTool.cmd, just right-click it then run as administrator.
This script will start a debug view app to capture spacedesk debug traces.
On step 5 it will prompt you to reproduce the issue(just connect the viewer app with black screen/display off status), make sure to do this before pressing any key to continue.
After the script is done, a folder will be created on the same folder as the script file which contains various log files that we need for analysis.
Please right-click it -> Send to -> Compressed (zipped) folder, then attach the *.zip file on your next reply.
Looking forward to your feedback.

Reply
Stoubar
Posts: 1
Registered
(@stoubar)
New Member
Joined: 9 months ago

Hello, i tried with debug, but when running the debug software the spacedesk Server justo close and dont open again. Another question, how can i attach the file?

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @stoubar,
The script includes restarting the spacedeskService that's why the spacedesk SERVER window will suddenly close, but you should be able to open it again upon Step 5, when the script prompt you to reproduce the issue.
Attach option should be visible below the text editor after your second post.

Reply
DTMK
Posts: 1
 DTMK
Registered
(@dtmk)
New Member
Joined: 7 months ago

hey, I have the same problem 'connected-display off'

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @dtmk,
Did you check the display settings window on your primary machine if the spacedesk display is detached?
What is your spacedesk Viewer type? Android/iOS/Windows/HTML5?
For further analysis, could you please run dxdiag.exe on your primary machine, click "Save All Information", then attach the output file on your next reply.
PS: Attach option should be visible on your side after your second post.

Reply
AustrianAviator
Posts: 2
Registered
(@austrianaviator)
New Member
Joined: 6 months ago

Hi, I seem to have the same issue unfortunately...
I have the Server running on my Laptop (Win 10 64-bit build 19042) and am trying to connect to my iPad Pro (3rd Gen, running iOS 13.5.1). I have tried connecting through the app as well as the HTML Viewer with no success. While the iPad says "Connected - Display OFF", the server shows no connection being made. 

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @austrianaviator,

Is your auto-reconnect enabled on your iOS Viewer app?
Did you notice any error notification on your primary machine upon connection attempt?
For further analysis, could you please run dxdiag.exe on your primary machine, click "Save All Information", then attach the output file on your next reply.
PS: Attach option should be visible on your side after your second post.

Reply
AustrianAviator
Posts: 2
Registered
(@austrianaviator)
New Member
Joined: 6 months ago

@spacedesklea
Thank you for the speedy reply. I have tried to connect with the auto-reconnect both enabled and disabled. Same result. There is also no apparent error message. 

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @austrianaviator,
Thanks for sending your dxdiag info.
It seems that you have splashtop installed on your primary machine.
You have to remove/uninstall splashtop then reboot before connecting spacedesk viewer.
For more info, please check Incompatible display hook driver chapter in our user manual https://spacedesk.net/user-manual/.

Reply
BlaineTheMonkey
Posts: 2
Registered
(@blainethemonkey)
New Member
Joined: 6 months ago

Hi, I also have the same problem: it connects, the connection appears on the server, but the IOS screen (I also tested it on Android) remains black and the message "CONNECTED - DISPLAY OFF" appears.

He won't let me attach the diagnostic file

 

- Primary machine operating system: Windows 10
- Secondary machine operating system: iOS

- Primary machines's Graphics adapter: AMD
- Network connection type: Wifi

Reply
ricardojo2008
Registered
(@ricardojo2008)
Joined: 5 months ago

New Member
Posts: 3
Posted by: @blainethemonkey

Hi, I also have the same problem: it connects, the connection appears on the server, but the IOS screen (I also tested it on Android) remains black and the message "CONNECTED - DISPLAY OFF" appears.

He won't let me attach the diagnostic file

 

- Primary machine operating system: Windows 10
- Secondary machine operating system: iOS

- Primary machines's Graphics adapter: AMD
- Network connection type: Wifi

Hello, la solución esta en el siguiente video:

removed link

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @blainethemonkey,
Attach option will be visible on your side after your second post.

Did you check on display settings window of your primary machine if there's a detached second display?
Did you also check if spacedesk SERVER window shows any indication that there's a connected viewer (e.g. connections count, on Network connections (remote) tab?

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi ricardojo2008,
Posting links is not allowed due to security issues.
Can you further describe the solution you found on that link?

Reply
stud001
Posts: 2
Registered
(@stud001)
New Member
Joined: 2 months ago

On both computers Windows 8.1. The secondary computer is a laptop. Spacedesk latest version. Everything worked fine, and suddenly on the laptop -  "connected - Display off". The only thing that happened was a sudden power outage, but I can't figure out how this affected the spacedesk. DxDiag is here <a title="DxDiag" href=" removed link " target="true"> removed link

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @stud001,

You mean after the power outage, spacedesk is only showing "display off" status?
Did you try to reboot your machine and try again?

PS: Attach option should be visible on your side after your second post.
Once the Attach option is visible on your side, please try to attach your dxdiag file.

Reply
stud001
Posts: 2
Registered
(@stud001)
New Member
Joined: 2 months ago

Thank you, Lea. Now everything is OK, despite the fact that, it seems to me, there was reboots before.

Reply
rldutiel
Posts: 1
Registered
(@rldutiel)
New Member
Joined: 5 days ago

Hello. I hope I am not too late to this thread to get help. I have, I think,  similar issue. I use a Windows 10 machine as my primary and an Ipad as my remote display. I have been running this successfully since the pandemic began. I just updated to the latest driver on my primary and then made sure my IOS was updated. All now have most recent updates.

And now my Ipad never connects to the primary.  I can see my IP address in the connection window, but when I try to connect, all I get is a black screen saying "Connecting to "my IP address".    This is very frustrating as it worked earlier this morning, but not now.

Increasing my frustration is that, as a test, I installed the secondary display app on my daughters hand me down, 9 year old Ipad and it works just fine. 

Sadly, I need to have it on my own Ipad for teaching. 

Any recommendations? Should I try and roll back the driver?

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @rldutiel
Can you try the following on your iPad:
- restart the iOS viewer app
- switch OFF then ON the wifi connection
- restart iPad device

Reply

spacedesk forum footer

Copyright © 2020 spacedesk Support Forum