Facebook Like Button

Welcome Visitor! Please Login or Register
Connected- Display ...
 
Share:
Notifications
Clear all

Connected- Display off  


muchman
Posts: 16
Registered
(@muchman)
Eminent Member
Joined: 1 month ago

Hello,

Please assist, I keep getting an error on the Spacedesk Primary machine. SpacedeskX10 Error Driver not available and then the Secondary display goes black with a message "Connected-Display OFF"

34 Replies
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @muchman,

What is your primary machine (Windows 10/8.1)? and graphics adapter (AMD/Intel/Nvidia)?
What is your Viewer type (Android/iOS/Windows)?
Are you connected over wired/wireless/USB tethering/Wifi direct?
For further analysis, could you please run dxdiag.exe on your primary machine, click "Save All Information", then attach the output file (dxdiag.txt) on your next reply.
PS: Attach option should be visible on your side after your second post.

Reply
muchman
Posts: 16
Registered
(@muchman)
Eminent Member
Joined: 1 month ago

Hi,

primary machine Windows 10 Pro 64 bit

Display drivers  Intel(R) HD Graphics 620

What is your Viewer type IOS

Connected over Wireless

 

 

Reply
muchman
Posts: 16
Registered
(@muchman)
Eminent Member
Joined: 1 month ago

 

Please find attach dxdiag logs

Reply
spren
Posts: 1
Registered
(@spren)
New Member
Joined: 2 weeks ago

Having same problem

Windows 10, 64bit

Radeon RX 580

Samsung Tab S3 (Android latest update)

USB tethered

I have the dxdiag info but don't see how to attach it here.

Thanks!

 

 

Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @muchman,
Thanks for sending your dxdiag info.
Could you please try our most recent spacedesk Driver v0.9.70 available on or website.
https://spacedesk.net/.

If the same problem still persist, we would like to analyze further the issue.
Please download the spacedesk diagnostic script here, then extract it.
https://www.dropbox.com/s/ilm5em35h0ygsfm/2020_spacedeskDiagnosticTool.zip?dl=0

Inside you will find spacedeskDiagnosticTool.cmd, just right-click it then run as administrator.
This script will start a debug view app to capture spacedesk debug traces.
On step 5 it will prompt you to reproduce the issue (by connecting the viewer app and wait for the issue to happen), make sure to do this before pressing any key to continue.
After the script is done, a folder will be created on the same folder as the script file which contains various log files that we need for analysis.
Please right-click it -> Send to -> Compressed (zipped) folder, then attach the *.zip file on your next reply.

Looking forward to your feedback.

Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @spren,
Attach option should be visible on your side after your second post.
Please also try the diagnostic procedure on my previous post.

 

Reply
muchman
Posts: 16
Registered
(@muchman)
Eminent Member
Joined: 1 month ago

Hi @Lea,

Please find attached logs

 

Regards

 

2.13.0.0
Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @muchman,
Thanks for sending the requested diagnostic files.
Based on the log file, you have VNC Mirror driver installed.
This is the first time we encounter this driver and it's probably conflicting with our spacedesk driver.
To confirm this, is it possible for you to uninstall this VNC Mirror driver on your primary machine?
Then reboot your primary machine and quickly check if spacedesk will work now on your side.

Reply
muchman
Posts: 16
Registered
(@muchman)
Eminent Member
Joined: 1 month ago

Hi @Lea,

I've uninstalled VNC mirror driver, but spacedesk is not working even after a reboot. Find attached logs

 

Regards

 

2.13.0.0
Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @muchman,
Thanks for quickly trying it.
It seems that spacedesk Graphics Adapter driver still has error.
Can you please try the following:
- run devmgmt.msc
- Go to display Adapters -> spacedesk Graphics adapter, if it has error (yellow exclamation mark) right-click it then select "Disable device"
- run services.msc, find spacedeskService and restart it
- try to connect again with spacedesk

If problem still persist, can you try to run the spacedesk v0970 msi installer and select "Repair".

Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

By the way, did you uninstall the VNC Mirror driver according to their instruction on the website? 
Please check here the Manual Uninstall steps: https://www.uvnc.com/products/mirror-driver.html

Reply
muchman
Posts: 16
Registered
(@muchman)
Eminent Member
Joined: 1 month ago

Hi @Lea,

I confirmed I uninstalled Real VNC  setup and then did a reboot. I've also disabled Spacedesk driver, restarted spacedesk service. I've repaired spacedesk v0970 msi but Secondary Viewer is not connecting to Primary PC

2.13.0.0
Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @muchman,
Thanks for double checking.

Now, please try to uninstall the spacedesk Driver then reboot your primary machine and try again to install.

By the way, do you have any pending Windows Update that needs to be installed?
Make sure that your Windows 10 is updated.

Reply
muchman
Posts: 16
Registered
(@muchman)
Eminent Member
Joined: 1 month ago

Hi @Lea,

There is no pending update. I've done as per request, uninstalled spacedesk, restarted PC and re-installed spacedesk. But still getting attached error on Primary PC

2.13.0.0
Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @muchman,
Thanks for quickly checking.
We are currently reviewing your diagnostic files for possible cause of the issue.
Can you also please send us the C:\Windows\INF\setupapi.app.txt file for further analysis.

Reply
muchman
Posts: 16
Registered
(@muchman)
Eminent Member
Joined: 1 month ago

Hi @Lea

Please find attached

2.13.0.0
Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @muchman,
Thanks.
Do you maybe have application verifier on your primary machine?
Is there any current active settings in it?

Is this the first time you try spacedesk?

Reply
muchman
Posts: 16
Registered
(@muchman)
Eminent Member
Joined: 1 month ago

Hi @Lea,

This is the first time am using spacedesk. I've not configure any setting manually on Primary PC

Regards

 

 

2.13.0.0
Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @muchman,
I see..
Can you please try to download the latest Intel Graphics 620 driver installer from the Intel website, and try to install/update it on your primary machine.
https://downloadcenter.intel.com/product/96551/Intel-HD-Graphics-620
Then let us know if it helps.
Looking forward to your feedback.

Reply
muchman
Posts: 16
Registered
(@muchman)
Eminent Member
Joined: 1 month ago

Hi @Lea,

 

I've updated to the most recent beta Version of Intel-HD-Graphics-620 but still not able to connect to this Primary PC

2.13.0.0
Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @muchman,
Thanks for trying it.

Could you please go to C:\ProgramData\Microsoft\WDF, then check if there's a recent WudfHost_ext__xxxx.dmp files and send it to us if there's any.
Note: ProgramData folder is hidden by default, in case you cannot find it you should enable first the "Show hidden files, folders and drives".
Just open a File Explorer -> View -> Options, on Folder Options window click View tab then click the "Show hidden files, folders and drives" to enable it then apply the changes.

Reply
muchman
Posts: 16
Registered
(@muchman)
Eminent Member
Joined: 1 month ago

Hi @Lea,

The folder is blank, even after showing hidden items

Regards

 

2.13.0.0
Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @muchman,
Ok, thanks.
Can you quickly search if you have "Application Verifier x64" on your primary machine. Maybe check on you Settings -> Apps & features list.
So far I can only reproduce the Code 31 error here if I have application verifier enabled.

Reply
muchman
Posts: 16
Registered
(@muchman)
Eminent Member
Joined: 1 month ago

Hi @Lea,

I've since installed windows SDK. I now have C:\Windows\System32\appverif.exe

Please guide on the next step

2.13.0.0
Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @muchman,
Can you search for the application verifier using search bar and try to run it?
Please check the screenshot below.

Reply
muchman
Posts: 16
Registered
(@muchman)
Eminent Member
Joined: 1 month ago

Hi @Lea,

Once I run it, the application starts a cmd screen and then cmd screen disappears immediately

Regards

2.13.0.0
Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @muchman,
Ok, I experienced the same thing here on one of our machine.
Could you please download PSTools here: https://docs.microsoft.com/en-us/sysinternals/downloads/pstools
- extract the files 
- run command prompt as administrator
- type the command:
C:\PSTools\PsExec.exe -i -s C:\Windows\System32\appverif.exe
Note: on your side just edit the directory where the PsTools folder is located (on my side I copied the PsTools folder on C:\ directory).

Then check if there's any entry in the Applications/Image name list.

Reply
muchman
Posts: 16
Registered
(@muchman)
Eminent Member
Joined: 1 month ago

Hi @Lea,

Please find attached. After executing this command

C:\PSTools\PsExec.exe -i -s C:\Windows\System32\appverif.exe

 

Regards

 

2.13.0.0
Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @muchman,
Now please check the driver verifier.
Just search for "verifier" then select "Display existing settings", and check if there's entry below "Verify these drivers".

Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

By the way, do maybe have any debugger app currently running on your primary machine?

Reply
muchman
Posts: 16
Registered
(@muchman)
Eminent Member
Joined: 1 month ago

Hi @Lea,

Please find attached after I run verifier. Currently, I have visual studio and windows debugger (windbg) installed

Regards

 

 

 

2.13.0.0
Reply
spacedesk Lea
Posts: 1565
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @muchman,
Ok thanks for the info.
Visual Studio and WinDbg should not have any conflict with spacedesk driver.
I also have it on my machine and spacedesk still works on my side.
Could you please run "msinfo32":
- click Software environment -> System Drivers, then File -> Export and save the exported file.
- click Software environment -> Services, then File -> Export and save the exported file.
Then send us the 2 exported files.

Reply
muchman
Posts: 16
Registered
(@muchman)
Eminent Member
Joined: 1 month ago

Hi @Lea,

Please find attached

Regards

2.13.0.0
Reply
rluzini
Posts: 0
Registered
(@rluzini)
New Member
Joined: 2 days ago

I Am facing the same problem - "connected - display OFF". I have installed and uninstalled the space desk in both machines (A desktop - server - and a laptop - client.

Primary: Windows 10 / Nvidia

Viewer: windows 10/Intel and Android.

Connected via ethernet cable (Windows) and WiFi (Android)

 

Reply

spacedesk forum footer

Copyright © 2020 spacedesk Support Forum