Facebook Like Button

Welcome Visitor! Please Login or Register
Auto connect to ser...
 
Share:
Notifications
Clear all

Auto connect to server can't be activated because option is disabled  


martin.szugat
Posts: 17
Registered
(@martin-szugat)
Eminent Member
Joined: 3 months ago

I can't activate the auto connect to server option because it is disabled (greyed). What can I do? Thansk for your help!

14 Replies
martin.szugat
Posts: 17
Registered
(@martin-szugat)
Eminent Member
Joined: 3 months ago

PS: The problem only occurs on the Windows 10 viewer version. It works well on the Windows 7 viewer version.

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @martin-szugat,
Yes, auto-connect option in spacedesk Windows 10 Viewer app is not yet available.
It is currently being implemented.
We will let you know as soon as its available.

Reply
martin.szugat
Posts: 17
Registered
(@martin-szugat)
Eminent Member
Joined: 3 months ago

OK, thanks!

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @martin-szugat,
FYI: Auto-connect feature is now available on spacedesk Windows 10 Viewer App, please update to latest version on Microsoft store.

Reply
flydog23
Posts: 20
Registered
(@flydog23)
Eminent Member
Joined: 1 month ago

Better check one thing out first...

when I (accidentally) enabled auto-connect on the current viewer, I discovered that I could no longer access the Options (upper right corner of app).  For some reason, I can see the Options only when I am disconnected from the server.  In the current state of the client software (in Beta, etc), I would postpone setting the auto-connect until the Options menu is accessible while connected.

Note that the only way I could get out of the dilemma was to uninstall and reinstall the Viewer with default (auto-connect off) settings.  Hope this helps.

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @flydog23,

Thanks for the input.
Are you referring to the Settings button which is displayed only in disconnected state?
Please check attached screenshot.

Reply
flydog23
Posts: 20
Registered
(@flydog23)
Eminent Member
Joined: 1 month ago

Yes, that is the setting button, which I referred to as option (sorry). As you stated, when connected to server, the settings are inaccessible.  So once you turn on auto-connect, I cannot figure out how to ever turn auto-connect off again, regaining settings access.

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @flydog23,

This is intended as we cannot allow settings changes while it's already connected - this logic is applied to all our viewer apps (Android and iOS too).
To disable the auto-connect, just run first the viewer app which will auto-connect then manually disconnect it and from there you can access the settings button to disable it.

Reply
flydog23
Posts: 20
Registered
(@flydog23)
Eminent Member
Joined: 1 month ago

Refresh my memory please...  how do I disconnect?

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

hi @flydog23,

When you open the UWP viewer app (with auto connect enabled), just manually disconnect it just hover/move your mouse on the top portion of the viewer screen so the menu bar become visible, it's where the disconnect button is located.

Reply
flydog23
Posts: 20
Registered
(@flydog23)
Eminent Member
Joined: 1 month ago

The menu bar does not become visible... just the solid “spacedesk VIEWER” title app bar appears, and I can’t position the mouse anywhere in that area.  The mouse is locked within the data area itself.

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @flydog23
Ahh the remote control is activated in the viewer, so you have to exit first from remote control via "Alt+Shift" key from your secondary machine.

Reply
flydog23
Posts: 20
Registered
(@flydog23)
Eminent Member
Joined: 1 month ago

Hmm..  I’m struggling with this one.  My secondary is a tablet, without an attached keyboard.  But I can open an OnScreen Keyboard, but I can’t seem to be able to do an Alt+Shift.  (I haven’t mastered how to do a multi-key combo on-screen keyboard)

Reply
spacedesk Lea
Posts: 2305
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @flydog23,
I also observed that the green menu bar I mentioned above is also not displaying when running the UWP Viewer app on Windows Simulator.
The workaround is to switch the server OFF on primary machine side, just click the spacedesk tray icon, click menu "..." button then OFF so the viewer app will disconnect and from there you can open now the settings and disable the auto-connect option.
This bug will be forwarded to the development team to fix.

Or if you like you can use the Windows Viewer 0.9.30 (desktop version) for now.

Reply

spacedesk forum footer

Copyright © 2020 spacedesk Support Forum