Facebook Like Button

Welcome Visitor! Please Login or Register
ATTENTION - UNINSTA...
 
Share:
Notifications
Clear all

[Sticky] ATTENTION - UNINSTALL PROBLEM ON SOME MACHINES! (PLEASE READ)  


spacedesk Lea
Posts: 2583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

ATTENTION - UNINSTALL PROBLEM ON SOME MACHINES!
- Some users report uninstall problems.
- We can only very sporadically reproduce.
- We are trying to fix soonest possible.
- This affects v0.9.90, v0.9.89 and possibly one or two earlier versions

TO FIX:
- First reboot the machine and try to uninstall again.
- If this does not help, then uninstall spacedesk Driver manually
- Read instruction manual how to uninstall manually.

INSTRUCTION MANUAL:
https://spacedesk.net/user-manual
SEE CHAPTER "Manual Uninstall (Troubleshooting Only)"

"If you are affected by this problem, please reply to this post.
Tell us your spacedesk version and your Windows version.
Please let us know if you could successfully uninstall after reboot or if you needed to uninstall manually as explained in the instruction manual"

14 Replies
morTimar
Posts: 1
Registered
(@mortimar)
New Member
Joined: 2 months ago

Had to go the manual path!

Reason I did uninstall: Could no longer connect my android device to the Win10 Connect app (screen mirror) to display the phones screen on my windows computer.

What I tried:

- remove through 'Programs & Features'

- by executing installation file again (spacedesk_driver_Win_10_64_v0989_BETA.msi)

- updateing with new driver (spacedesk_driver_Win_10_64_v0990_BETA.msi)

- Microsoft Fix

 

All attempts had in common that the windows malware protection service was the 2nd highest CPU active process right after a MSIxyz.tmp process. I could get the malware protection activities covered by temporarly adding that temporary installation process as an exception but without any further success. The uninstall process was eating up CPU but did not moved on. Killing the process finally got me an error message that a part of the installation did not finish as expected

 

Always had the progress bar stop at maybe 10 percent. Similar to the other posts.

Manual uninstall instructions do not meet always my experience.

For example in case you decide to tick the "remove driver" while you are uninstalling things in the device manager you will not see some files which are listed in your file list in that post: removed link

 

my system:

- Win10 pro (10.0.19042)

- i5, Intel UHD 620

Reply
vlsisfrm
Posts: 1
Registered
(@vlsisfrm)
New Member
Joined: 2 months ago

Run into this while upgrading from 0.9.89 to 0.9.90.

  1. I chose to perform an upgrade that never finished. Forced stopped via task manager
  2. Reboot
  3. Tried to install 0.9.90 again. Same issue.
  4. Reboot
  5. Tried to uninstall spacedesk driver via "add/remove programs". Uninstall started but got frozen at about 25%.
  6. Reboot
  7. Tried to uninstall spacedesk driver via "add/remove programs". Uninstall started but got frozen at about 25%.
  8. Reboot
  9. Followed the "Manual Uninstall (Troubleshooting Only)"
  10. Started installation of 0.9.90. I got a message about spacedesk driver being already installed. I chose to upgrade. It finished successfully.

Windows 10 Enterprise

 

Reply
niong108
Posts: 2
Registered
(@niong108)
New Member
Joined: 2 months ago

Just wanted to jump into the discussion related to this problem. 

The setup app, after you initialize an uninstall procedure creates a log file spacedeskSetup.log in the "Users/Public" folder and this file creation ends up in a crazy loop i.e. as the setup cannot end the file keeps getting bigger. In my case, it grew to 25 GB !!! 

So please look this up too. 

Reply
lusterisk
Posts: 7
Registered
(@lusterisk)
Active Member
Joined: 2 months ago

hello, lea. I followed the instruction but I cannot seem to uninstall the spacedesk virtual HID Device, as that option is not even there and I don't see the children below spacedesk virtual HID Device too. so I want to ask for help.  im stuck on vers 0.9.89 and I'm using windows 10.

Reply
spacedesk Lea
Posts: 2583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @niong108, Hi @lusterisk,

Please try the following:
- delete the C:\User\Public\spacedeskSetup.log file
- reboot your primary machine
- follow the steps on manual uninstall from our user manual
Note: The endless loop that causes the bigger log file, was due to failed uninstall of our spacedesk virtual HID device in version 0989.
So in device manager, you have to uninstall this device manually.

Posted by: @spacedesklea

https://spacedesk.net/user-manual
SEE CHAPTER "Manual Uninstall (Troubleshooting Only)"

@lusterisk,
On device manager, did you click the View tab -> Devices by connection, before searching for spacedesk virtual HID device?

Reply
niong108
Posts: 2
Registered
(@niong108)
New Member
Joined: 2 months ago

Hi Lea,

I followed the steps on manual uninstall from our user manual and everything is fine now.

I just wanted to note for other users that there might be a huge log file on their disk if they tried to uninstall the app.

 

Reply
spacedesk Lea
Posts: 2583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @niong108,
Thanks for the feedback.
This uninstall issue on v0989 has been fixed on later versions (v0.9.90 - 93) of installer.
But we are still working on the automatic fix for those who still have the broken v0989 installer.

Reply
lusterisk
Posts: 7
Registered
(@lusterisk)
Active Member
Joined: 2 months ago

hi @spacedesklea,

i have deleted the spacedesk virtual HID device, which means i have done all the steps that is showed in the CHAPTER "Manual Uninstall (Troubleshooting Only)".

But now i tried to download spacedesk_driver_Win_10_64_v0993_BETA.msi, and i encountered this situation. (look at problem.pdf)

what should i do now to install it properly?

 

Reply
spacedesk Lea
Posts: 2583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @lusterisk,

Just click Yes to proceed with version update.

Reply
lusterisk
Posts: 7
Registered
(@lusterisk)
Active Member
Joined: 2 months ago

hi @spacedesklea,

please read the whole pdf to see the full context.

Reply
lusterisk
Posts: 7
Registered
(@lusterisk)
Active Member
Joined: 2 months ago

here is what the log said:

Reply
spacedesk Lea
Posts: 2583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @lusterisk,
Thanks for sending the spacedesk setup log file.
Can you also please send us the setupapi.dev.log file located in C:\Windows\INF ?

Reply
lusterisk
Posts: 7
Registered
(@lusterisk)
Active Member
Joined: 2 months ago

@spacedesklea

here it is. i have to change it to txt to be able to upload so change it back to log as u wish!

Reply
spacedesk Lea
Posts: 2583
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @lusterisk,
Thanks for sending the requested file.
Have you already tried to reboot your primary machine then run again the new v0.9.93 MSI installer?
Did you still get the same problem?

Reply

spacedesk forum footer

Copyright © 2020 spacedesk Support Forum