Facebook Like Button

Welcome Visitor! Please Login or Register
Android active Teth...
 
Share:
Notifications
Clear all

[Solved] Android active Tethering is on, still can't detect primary server  


balint
Posts: 7
Registered
(@balint)
Active Member
Joined: 10 months ago

I'm on the same wifi as well with the phone to my win 10 laptop. 
Win 10 laptop works well with another laptop via LAN cable. 

Now, I want to try using my phone as well, it can't detect the server. I typed the IP for manually adding it, but it gets stuck on IP-Validation in progress...

what can I do?

 

9 Replies
spacedesk Lea
Posts: 1590
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @balint,
What kind of tethering do you mean by "active tethering"? Did you setup a USB tethering between your phone and primary machine (Win 10 laptop)?
Or do you want to connect over the wifi network?

Posted by: @balint

Win 10 laptop works well with another laptop via LAN cable. 

Is it a direct connection (cross over ethernet connection) that does not go over the router?
Or is it the same network as the wifi network you mentioned, that goes over the same router?

Reply
balint
Posts: 7
Registered
(@balint)
Active Member
Joined: 10 months ago

Hia Lea, 

I prefer cable connection as WIFI has been always just a bit too slow for me to consider it a proper option. 

Tethering:

I did the same way when I want to share internet from my phone to my laptop. Usb cable connection then going into the settings. By active, I meant that I got a feedback messages that it's connected with a device. 

 

My laptop to laptop setup (I use it currently as well:). Is a local LAN to LAN cable. 
Coming to think about it, both laptops are on the same Wifi at it doesn't show the wifi connection option when I connect it, so the network seems to be not enabled here. 

Not that it would matter for my purposes, which is only cable based, device to device connection. 

Thanks

Reply
balint
Posts: 7
Registered
(@balint)
Active Member
Joined: 10 months ago

Hia Lea, 

I prefer cable connection as WIFI has been always just a bit too slow for me to consider it a proper option. 

Tethering:

I did the same way when I want to share internet from my phone to my laptop. USB cable connection then going into the settings. By active, I meant that I got feedback messages that it's connected with a device. 

 

My laptop to laptop setup (I use it currently as well:). Is a local LAN to LAN cable. 
Coming to think about it, both laptops are on the same Wifi at it doesn't show the wifi connection option when I connect it, so the network seems to be not enabled here. 

Not that it would matter for my purposes, which is only cable-based, device to device connection. 

Thanks

Reply
spacedesk Lea
Posts: 1590
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago
Which laptop is connected to your phone via USB tethering?
Is it the primary or the secondary machine?

Let's say Laptop 1 is the primary machine, then Laptop 2 is the secondary machine.
Laptop 1 should be the one USB tethered to the android phone to establish a network connection between the two machine.
Then Laptop 1 and Laptop 2 are both connected via LAN cable.
If this is the case, spacedesk Viewer app on Laptop 2 and Android phone should be able to discover the IP address of your Laptop 1 which is the primary machine / server.

Posted by: @balint

Coming to think about it, both laptops are on the same Wifi at it doesn't show the wifi connection option when I connect it, so the network seems to be not enabled here. 

If wifi is not visible probably due to network adapter priority of your machine.
You can easily configure it on your Windows machine through the following:
- Open Windows Settings -> Network and Internet -> Change adapter option
- In there you will see the wired adapter (Ethernet) for your LAN connection, right-click -> Properties, click on Internet Protocol Version 4 (TCP/IPv4) -> Properties -> Advanced
- Uncheck the "Automatic metric" and set the value to any value(e.g. 7), then click OK to finish it.
- Do the same with the Wireless/WiFi adapter, this time set the Automatic metric value lower than the value (e.g. 5) you set in Ethernet adapter.
Which ever has the lower Automatic metric value will be on top priority.
- Restart your machine and check.

Reply
balint
Posts: 7
Registered
(@balint)
Active Member
Joined: 10 months ago

Thanks Lea, I don't worry regarding the Wifi, I won't use that connection anyways. 

When I tried it was only laptop 1 and the phone, the secondary laptop was not connected. But didn't change anything so wanted to remark that it works with laptop 1. 

"Laptop 1 should be the one USB tethered to the android phone to establish a network connection between the two machine." 
Hmm might be the issue that I start the tethering from my phone? I guess that's how it was in the guides. 

Reply
spacedesk Lea
Posts: 1590
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago
With Laptop 1 and android phone connected via USB tethering, you can still connect Laptop 1 and Laptop 2 with LAN cable.
By the way, is it a cross over ethernet cable connection between the two laptops?
Just try the manual settings of Automatic Metric value for each network adapters. Make sure Ethernet adapter has lower value than the Remote NDIS adapter.
Reply
balint
Posts: 7
Registered
(@balint)
Active Member
Joined: 10 months ago
By the way, is it a cross over ethernet cable connection between the two laptops?

 

Just try the manual settings of Automatic Metric value for each network adapters. Make sure Ethernet adapter has lower value than the Remote NDIS adapter.

Lea, I'm not sure what you mean by that question? I just installed the 2 software on the 2 laptops and plugged in the cables into the RJ45 and I'm able to connect to the primary. I didn't change anything nor do I have knowledge about this. 

Regarding this Automatic Metric value - would that help with the USB Tethering? I'll try to find more information on this then.

Thank you!

Reply
spacedesk Lea
Posts: 1590
Moderator
(@spacedesklea)
Illustrious Member
Joined: 2 years ago

Hi @balint,
You can follow the steps below for setting the Automatic metric.

Posted by: @spacedesklea

- Open Windows Settings -> Network and Internet -> Change adapter option
- In there you will see the wired adapter (Ethernet) for your LAN connection, right-click -> Properties, click on Internet Protocol Version 4 (TCP/IPv4) -> Properties -> Advanced
- Uncheck the "Automatic metric" and set the value to any value(e.g. 7), then click OK to finish it.

Then do the same with the network adapter for USB tethering - the Remote NDIS adapter.

Reply
balint
Posts: 7
Registered
(@balint)
Active Member
Joined: 10 months ago

Worked well! Thank you very much!

Reply

spacedesk forum footer

Copyright © 2020 spacedesk Support Forum